aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-14 15:36:39 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-17 10:36:25 +0100
commit7a315b0b5d6aa91695853a8647383876e4b49a7a (patch)
treeca99d91b9ec9408e37d30f2983847fc5a500d4a7 /Makefile
parent720b99215da295a2e7b4acdef30b58bec6acedc2 (diff)
downloadupstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.gz
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.bz2
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.zip
build: implement make check and make package/X/check
This is intended to be used for a wide array of package sanity checks. The first check that is implemented is for the hash of downloaded files. It checks: - Missing hash - Use of SHA256 instead of MD5 - dl/<file> hash not matching hash in makefile - deprecated MD5SUM variable The deprecated MD5SUM variable check is skipped for feeds/ until OpenWrt is updated as well Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 59320d4a20..51ed5a1132 100644
--- a/Makefile
+++ b/Makefile
@@ -44,6 +44,7 @@ $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUI
$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
$(package/stamp-install): $(package/stamp-compile)
$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+check: $(tools/stamp-check) $(toolchain/stamp-check) $(package/stamp-check)
printdb:
@true