aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-17 22:52:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-17 22:52:59 +0000
commit6a0c7478207d03871e433e554829e6157897f326 (patch)
tree2b6844c3bb5831e464ea4625441fd91543579b32 /Makefile
parentef69b8d26a7c4250ed183cc2e1df394c0ef62282 (diff)
downloadupstream-6a0c7478207d03871e433e554829e6157897f326.tar.gz
upstream-6a0c7478207d03871e433e554829e6157897f326.tar.bz2
upstream-6a0c7478207d03871e433e554829e6157897f326.zip
move target/default/target_skeleton into package/base-files, put all the default files in ipkg packages, cleanup some junk in toolchain/, toolchain/ no longer changes build_mipsel/root
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1494 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 1b8d968a09..45a9ba7ffb 100644
--- a/Makefile
+++ b/Makefile
@@ -77,9 +77,9 @@ package_install: package_compile toolchain
# In this section, we need .config
include .config.cmd
-world: $(DL_DIR) $(BUILD_DIR) configtest target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
+world: $(DL_DIR) $(BUILD_DIR) configtest toolchain_install package_install target_install package_index
-.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install configtest
+.PHONY: all world clean dirclean distclean image_clean target_clean source target_install toolchain_install package_install configtest
configtest:
-cp .config .config.test
@@ -90,9 +90,6 @@ package_index:
$(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages \
)
-target_prepare:
- $(MAKE) -C target prepare
-
target_compile:
$(MAKE) -C target compile