aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-06-27 18:51:25 +0200
committerJo-Philipp Wich <jo@mein.io>2018-06-27 18:54:09 +0200
commit681e825f8fbf59a32c3b09810b2a3fef29880c63 (patch)
treec82d2b994edd8ef22f61e59ab22c87dd6919ea63 /Makefile
parent6e3c2d757a5745dee5cce0b53175b56ad3621d73 (diff)
downloadupstream-681e825f8fbf59a32c3b09810b2a3fef29880c63.tar.gz
upstream-681e825f8fbf59a32c3b09810b2a3fef29880c63.tar.bz2
upstream-681e825f8fbf59a32c3b09810b2a3fef29880c63.zip
build: include package directory in sha256sums when running on buildbot
In order to be able to better compare files to sync in the future, include all BIN_DIR subdirectories in the checksum calculation. To not break existing applications, restrict the recursive checksumming to CONFIG_BUILDBOT for now. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 0a1f96a973..e38d44a810 100644
--- a/Makefile
+++ b/Makefile
@@ -85,7 +85,7 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
fi
checksum: FORCE
- $(call sha256sums,$(BIN_DIR))
+ $(call sha256sums,$(BIN_DIR),$(CONFIG_BUILDBOT))
diffconfig: FORCE
mkdir -p $(BIN_DIR)