aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-22 13:47:24 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-22 13:47:40 +0100
commit664918d891f3d29f09c15b0abe6616bbfdb2d0c6 (patch)
treebae6a57fd505763ff398840008e2d8d6dba51c74 /Makefile
parent2990a21058243b067bb56fed36ee69205595993e (diff)
downloadupstream-664918d891f3d29f09c15b0abe6616bbfdb2d0c6.tar.gz
upstream-664918d891f3d29f09c15b0abe6616bbfdb2d0c6.tar.bz2
upstream-664918d891f3d29f09c15b0abe6616bbfdb2d0c6.zip
Revert "build: always run package/cleanup before package/compile"
This reverts commit 2990a21058243b067bb56fed36ee69205595993e. This introduces a race condition, let's fix this in buildbot instead. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 648fef5b86..a26eeee0a8 100644
--- a/Makefile
+++ b/Makefile
@@ -41,7 +41,7 @@ else
$(toolchain/stamp-compile): $(tools/stamp-compile)
$(target/stamp-compile): $(toolchain/stamp-compile) $(tools/stamp-compile) $(BUILD_DIR)/.prepared
-$(package/stamp-compile): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
$(package/stamp-install): $(package/stamp-compile)
$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
check: $(tools/stamp-check) $(toolchain/stamp-check) $(package/stamp-check)