aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-28 18:40:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-28 18:40:37 +0000
commit61f503c77ac7ce958ca951707a69d7a9d9327599 (patch)
treeb5b95ed0d8dd3d2c5f72a073a8c67c290ca28baf /Makefile
parent98caacae20fb2c9b44f6c41896bba822973750f7 (diff)
downloadupstream-61f503c77ac7ce958ca951707a69d7a9d9327599.tar.gz
upstream-61f503c77ac7ce958ca951707a69d7a9d9327599.tar.bz2
upstream-61f503c77ac7ce958ca951707a69d7a9d9327599.zip
add a "make prepare" target which builds everything up to target/compile, useful for scripts/deptest.sh
SVN-Revision: 16153
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 6cf4a4b1e0..db79274c9a 100644
--- a/Makefile
+++ b/Makefile
@@ -48,6 +48,8 @@ $(BUILD_DIR)/.prepared: Makefile
@mkdir -p $$(dirname $@)
@touch $@
+prepare: $(target/stamp-compile)
+
clean: FORCE
$(_SINGLE)$(SUBMAKE) target/linux/clean
rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)