aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-06 16:01:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-06 16:01:06 +0000
commit44cd20b8023f6f2fca50c32772229590b179756d (patch)
tree814262a8291ca31c2261c2028238ecb44447ab75 /Makefile
parent5c91b34ed732afddfcb15fdf857f6939c050dfb1 (diff)
downloadupstream-44cd20b8023f6f2fca50c32772229590b179756d.tar.gz
upstream-44cd20b8023f6f2fca50c32772229590b179756d.tar.bz2
upstream-44cd20b8023f6f2fca50c32772229590b179756d.zip
build: rework the package/install step - collect package install lists during package/compile, then install all packages at once
SVN-Revision: 33631
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 44b4e944eb..57575eac54 100644
--- a/Makefile
+++ b/Makefile
@@ -40,11 +40,9 @@ else
$(toolchain/stamp-install): $(tools/stamp-install)
$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
-$(package/stamp-cleanup): $(target/stamp-compile)
-$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-compile): $(target/stamp-compile)
$(package/stamp-install): $(package/stamp-compile)
-$(package/stamp-rootfs-prepare): $(package/stamp-install)
-$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
printdb:
@true
@@ -86,7 +84,7 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
fi
prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
-world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
+world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
$(_SINGLE)$(SUBMAKE) -r package/index
# update all feeds, re-create index files, install symlinks