aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-04 09:03:50 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-04 11:03:53 +0100
commit2a72a916ab24b7c844886444d741fcb5d6191596 (patch)
tree52596ed90579b83dbc17aa3b1d25aee905166330 /Makefile
parent38a8cea063ee25971bc5a9e8842edda280ed8513 (diff)
downloadupstream-2a72a916ab24b7c844886444d741fcb5d6191596.tar.gz
upstream-2a72a916ab24b7c844886444d741fcb5d6191596.tar.bz2
upstream-2a72a916ab24b7c844886444d741fcb5d6191596.zip
build: add diffconfig target
Add a "diffconfig" build target which stores the output of "scripts/diffconfig.sh" as "config.seed" in the image output directory and invoke that target by default. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 51ed5a1132..3450f7e297 100644
--- a/Makefile
+++ b/Makefile
@@ -87,9 +87,13 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
checksum: FORCE
$(call sha256sums,$(BIN_DIR))
+diffconfig: FORCE
+ $(SCRIPT_DIR)/diffconfig.sh > $(BIN_DIR)/config.seed
+
prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
$(_SINGLE)$(SUBMAKE) -r package/index
+ $(_SINGLE)$(SUBMAKE) -r diffconfig
$(_SINGLE)$(SUBMAKE) -r checksum
.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean