aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorClemens Fruhwirth <clemens@endorphin.org>2021-01-29 19:57:37 +0100
committerPetr Štetiar <ynezz@true.cz>2021-03-03 22:51:39 +0100
commit1f5e7224868109a170a9248d18f8d2b6124e9c5a (patch)
tree4b117c6e5f3c6ec1d48a1b55640fecb5da4aa2d5 /Makefile
parentcae69d558135456976b8fc6cb08530d1358cf6d5 (diff)
downloadupstream-1f5e7224868109a170a9248d18f8d2b6124e9c5a.tar.gz
upstream-1f5e7224868109a170a9248d18f8d2b6124e9c5a.tar.bz2
upstream-1f5e7224868109a170a9248d18f8d2b6124e9c5a.zip
Revert "build: replace which with Bash command built-in"
This reverts commit c7aec47e5e3a3ff7b5fdaa11cd1e62cae6746acb. The original commit replaces 'which' with 'command'. Sadly most of them are not equivalent and for 'which -a', there is no easy replacements that would not reimplement PATH parsing logic. Hence revert. Keeping a dependency on which is absolutely fine. Signed-off-by: Clemens Fruhwirth <clemens@endorphin.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index aecee6929e..e18bc18608 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
world:
-DISTRO_PKG_CONFIG:=$(shell command -pv pkg-config | grep -E '\/usr' | head -n 1)
+DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1)
export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
ifneq ($(OPENWRT_BUILD),1)