aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-02 11:34:22 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-02 11:35:45 +0000
commit1b6209203d4e403b4c6b124d1222d0a4ad69d37f (patch)
treec96f377553a0ade402ca92a4d99f3cdbd5addedb /Makefile
parent81d8f874b12e73af722be91f6e847abb08233877 (diff)
downloadupstream-1b6209203d4e403b4c6b124d1222d0a4ad69d37f.tar.gz
upstream-1b6209203d4e403b4c6b124d1222d0a4ad69d37f.tar.bz2
upstream-1b6209203d4e403b4c6b124d1222d0a4ad69d37f.zip
Revert "build: use config.site generated by autoconf-lean, drop hardcoded sitefiles"
This reverts commit f439e291304a93b982e912dc91b80ca950a594f3. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index d3c51761e9..aecee6929e 100644
--- a/Makefile
+++ b/Makefile
@@ -82,6 +82,12 @@ endif
# check prerequisites before starting to build
prereq: $(target/stamp-prereq) tmp/.prereq_packages
+ @if [ ! -f "$(INCLUDE_DIR)/site/$(ARCH)" ]; then \
+ echo 'ERROR: Missing site config for architecture "$(ARCH)" !'; \
+ echo ' The missing file will cause configure scripts to fail during compilation.'; \
+ echo ' Please provide a "$(INCLUDE_DIR)/site/$(ARCH)" file and restart the build.'; \
+ exit 1; \
+ fi
$(BIN_DIR)/profiles.json: FORCE
$(if $(CONFIG_JSON_OVERVIEW_IMAGE_INFO), \