aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-18 17:56:13 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-18 23:57:09 +0100
commit131db366a3785a72b6e742f1842d29c1ad200601 (patch)
tree120cf96c9cda355e076984d671cd19ef6d5bc5c2 /Makefile
parent7a523569f7f403cdd7c2074cc49920f1dd7ecc70 (diff)
downloadupstream-131db366a3785a72b6e742f1842d29c1ad200601.tar.gz
upstream-131db366a3785a72b6e742f1842d29c1ad200601.tar.bz2
upstream-131db366a3785a72b6e742f1842d29c1ad200601.zip
build: remove separate /install step for host builds
Reduces the number of recursive make invocations Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index c1a7285c83..a26eeee0a8 100644
--- a/Makefile
+++ b/Makefile
@@ -39,8 +39,8 @@ else
include tools/Makefile
include toolchain/Makefile
-$(toolchain/stamp-install): $(tools/stamp-install)
-$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
+$(toolchain/stamp-compile): $(tools/stamp-compile)
+$(target/stamp-compile): $(toolchain/stamp-compile) $(tools/stamp-compile) $(BUILD_DIR)/.prepared
$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
$(package/stamp-install): $(package/stamp-compile)
$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
@@ -91,7 +91,7 @@ diffconfig: FORCE
mkdir -p $(BIN_DIR)
$(SCRIPT_DIR)/diffconfig.sh > $(BIN_DIR)/config.seed
-prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
+prepare: .config $(tools/stamp-compile) $(toolchain/stamp-compile)
world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
$(_SINGLE)$(SUBMAKE) -r package/index
$(_SINGLE)$(SUBMAKE) -r diffconfig