aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-03-10 15:13:40 +0000
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-03-10 20:44:30 +0000
commit0c4d91f121b7a3660dbf433a8a6858573a86d137 (patch)
tree33bdc5c3010a0311520d857d8681230909ceae05 /Makefile
parentd369d92fc7ed2970540235b27441f75a81ef171b (diff)
downloadupstream-0c4d91f121b7a3660dbf433a8a6858573a86d137.tar.gz
upstream-0c4d91f121b7a3660dbf433a8a6858573a86d137.tar.bz2
upstream-0c4d91f121b7a3660dbf433a8a6858573a86d137.zip
build: clean menuconfig utility as part of dirclean
When sharing a common build directory between different build platforms eg. macos v docker based linux v virtual machine, a 'make dirclean' isn't quite enough to clean all the platform related binaries. The 'conf' and 'mconf' aka 'make menuconfig/defconfig & friends' utilities remain. Clean those as part of 'dirclean' so they get rebuilt for the current platform on the next 'make' Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 181c33b180..fd705a37ad 100644
--- a/Makefile
+++ b/Makefile
@@ -60,6 +60,7 @@ clean: FORCE
dirclean: clean
rm -rf $(STAGING_DIR_HOST) $(STAGING_DIR_HOSTPKG) $(TOOLCHAIN_DIR) $(BUILD_DIR_BASE)/host $(BUILD_DIR_BASE)/hostpkg $(BUILD_DIR_TOOLCHAIN)
rm -rf $(TMP_DIR)
+ $(MAKE) -C $(TOPDIR)/scripts/config clean
ifndef DUMP_TARGET_DB
$(BUILD_DIR)/.prepared: Makefile