aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKien Truong <duckientruong@gmail.com>2022-09-10 15:25:35 +0700
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-02 22:25:49 +0200
commitfea7478f2d44da539f7ebbabeb58cde7ef23275e (patch)
treed296ff3b715828c50592373e6a25d24a424604b7
parentb2db4fa956254ae6714750367ea2476ba71e90c8 (diff)
downloadupstream-fea7478f2d44da539f7ebbabeb58cde7ef23275e.tar.gz
upstream-fea7478f2d44da539f7ebbabeb58cde7ef23275e.tar.bz2
upstream-fea7478f2d44da539f7ebbabeb58cde7ef23275e.zip
iproute2: add missing libbpf dependency
This patch adds libbpf to the dependencies of tc-mod-iptables. The package tc-mod-iptables is missing libbpf as a dependency, which leads to the build failure described in bug #9491 LIBBPF_FORCE=on set, but couldn't find a usable libbpf The build dependency is already automatically added because some other packages from iproute2 depend on libbpf, but bpftools has multiple build variants. With multiple build variants none gets build by default and the build system will not build bpftools before iproute2. Fixes: #9491 Signed-off-by: Kien Truong <duckientruong@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit fa468d4bcdc7e6eb84ea51d9b05368ed87c43aae)
-rw-r--r--package/network/utils/iproute2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index afad0e79d6..939dfa9e8b 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -82,7 +82,7 @@ define Package/tc-mod-iptables
$(call Package/iproute2/Default)
TITLE:=Traffic control module - iptables action
VARIANT:=tcfull
- DEPENDS:=+libxtables
+ DEPENDS:=+libxtables +libbpf
endef
define Package/genl