aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-22 17:41:15 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 12:08:23 +0100
commitfb19fb868cf5f1426ada869e4ad5b139a41ba78e (patch)
tree0b757549f6c0b85ec83cfd684aaffc5f20784eb7
parenteca05bc4ccbba7d6cc718cdb66cba14c93aff663 (diff)
downloadupstream-fb19fb868cf5f1426ada869e4ad5b139a41ba78e.tar.gz
upstream-fb19fb868cf5f1426ada869e4ad5b139a41ba78e.tar.bz2
upstream-fb19fb868cf5f1426ada869e4ad5b139a41ba78e.zip
libcxx: Depenency fixes
Don't build with uClibc-ng. It's totally unsupported as several functions are missing. Make the musl libc support conditional. Fix hash with make check FIXUP=1. Apparently I based the Makefile off of libedit and forgot to fix the hash. Signed-off-by: Rosen Penev <rosenp@gmail.com> Fixes: 856ea2bad3b3 ("libcxx: Add package")
-rw-r--r--config/Config-build.in1
-rw-r--r--package/libs/libcxx/Makefile8
2 files changed, 5 insertions, 4 deletions
diff --git a/config/Config-build.in b/config/Config-build.in
index bde5730e76..c0e4d869f8 100644
--- a/config/Config-build.in
+++ b/config/Config-build.in
@@ -199,6 +199,7 @@ menu "Global build settings"
config USE_LIBCXX
bool "libc++"
+ depends on !USE_UCLIBC
config USE_LIBSTDCXX
bool "libstdc++"
diff --git a/package/libs/libcxx/Makefile b/package/libs/libcxx/Makefile
index c1fa1d6b07..695b0398fe 100644
--- a/package/libs/libcxx/Makefile
+++ b/package/libs/libcxx/Makefile
@@ -7,12 +7,12 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libcxx
PKG_VERSION:=9.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://git.llvm.org/git/libcxx
PKG_SOURCE_VERSION:=2076f539f410805ef88692b9c0ce0a0b882a7680
-PKG_MIRROR_HASH:=6dff036660d478bfaa14e407fc5de26d22da1087118c897b1a3ad2e90cb7bf39
+PKG_MIRROR_HASH:=d527880a18dec9109575c76717cf5288fb91c11381b9d261cae2e5bebcbdab2e
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
PKG_LICENSE:=MIT
@@ -42,8 +42,8 @@ CMAKE_OPTIONS += \
-DLIBCXX_INCLUDE_BENCHMARKS=OFF \
-DLIBCXX_INCLUDE_DOCS=OFF \
-DLIBCXX_INCLUDE_TESTS=OFF \
- -DLIBCXX_HAS_MUSL_LIBC=ON \
- -DLIBCXX_STANDALONE_BUILD=ON
+ -DLIBCXX_STANDALONE_BUILD=ON \
+ -DLIBCXX_HAS_MUSL_LIBC=$(if $(CONFIG_USE_MUSL),ON,OFF)
TARGET_CXXFLAGS += -D_LIBCPP_DISABLE_DEPRECATION_WARNINGS -Wno-attributes -flto
TARGET_LDFLAGS += -Wl,--as-needed