aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-05-15 19:15:10 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-05-15 19:15:10 +0000
commitfa8c4aa1644ef3a1c1af3b0e245ef0cad19209cc (patch)
tree676ea5c3bcefa666b1cdefc6425a0b870df267ad
parentbdf2a0310735770f0b8bff733841621bc3c07088 (diff)
downloadupstream-fa8c4aa1644ef3a1c1af3b0e245ef0cad19209cc.tar.gz
upstream-fa8c4aa1644ef3a1c1af3b0e245ef0cad19209cc.tar.bz2
upstream-fa8c4aa1644ef3a1c1af3b0e245ef0cad19209cc.zip
fix 2.6.30 lzma tuning patch to output file size at end of kernel, otherwise decompressor remains stuck
SVN-Revision: 21458
-rw-r--r--target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch b/target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch
index 7c75ff98bc..d137bdfc88 100644
--- a/target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch
+++ b/target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch
@@ -1,17 +1,17 @@
Index: linux-2.6.30.10/scripts/Makefile.lib
===================================================================
---- linux-2.6.30.10.orig/scripts/Makefile.lib 2010-05-05 10:55:06.000000000 +0200
-+++ linux-2.6.30.10/scripts/Makefile.lib 2010-05-05 10:55:55.000000000 +0200
+--- linux-2.6.30.10.orig/scripts/Makefile.lib 2010-05-15 16:46:57.000000000 +0200
++++ linux-2.6.30.10/scripts/Makefile.lib 2010-05-15 18:53:02.000000000 +0200
@@ -204,4 +204,4 @@
# ---------------------------------------------------------------------------
quiet_cmd_lzma = LZMA $@
-cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
-+cmd_lzma = lzma e $< $@ -lc8 -eos
++cmd_lzma = (lzma e $< -lc8 -eos -so && $(size_append) $<) > $@ || (rm -f $@ ; false)
Index: linux-2.6.30.10/arch/x86/include/asm/boot.h
===================================================================
---- linux-2.6.30.10.orig/arch/x86/include/asm/boot.h 2009-12-04 07:00:07.000000000 +0100
-+++ linux-2.6.30.10/arch/x86/include/asm/boot.h 2010-05-05 10:55:23.000000000 +0200
+--- linux-2.6.30.10.orig/arch/x86/include/asm/boot.h 2010-05-15 16:45:57.000000000 +0200
++++ linux-2.6.30.10/arch/x86/include/asm/boot.h 2010-05-15 16:46:58.000000000 +0200
@@ -13,7 +13,7 @@
+ (CONFIG_PHYSICAL_ALIGN - 1)) \
& ~(CONFIG_PHYSICAL_ALIGN - 1))