aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Aldrian <dev.aldrian@gmail.com>2021-04-27 20:14:34 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-05-28 01:12:21 +0200
commitf755d81999b1745bc156ac53f10e8043c9def3de (patch)
treebaf5d79bd1b14e37ae45cffa22abd8015a47210e
parent53b9cc442f9ba33c66f78ee0a1fda4bb71ddd679 (diff)
downloadupstream-f755d81999b1745bc156ac53f10e8043c9def3de.tar.gz
upstream-f755d81999b1745bc156ac53f10e8043c9def3de.tar.bz2
upstream-f755d81999b1745bc156ac53f10e8043c9def3de.zip
ramips: add support for Wavlink WL-WN578A2
This commit adds support for the Wavlink WL-WN578A2 dual-band wall-plug wireless router. This device is also sold under the name SilverCrest SWV 733 A2. Device Specifications: - CPU: MediaTek MT7628AN (580MHz) - Flash: 8MB - RAM: 64MB - Bootloader: U-Boot - Ethernet: 2x 10/100 Mbps - 2.4 GHz: 802.11b/g/n SoC - 5 GHz: 802.11a/n/ac MT7610E - Antennas: internal - 4 green LEDs: WPS/Power, LAN, WAN, wifi-low, wifi-med, wifi-high - Buttons: Reset, WPS - Sliding mode switch: AP, repeater, client - Small sliding power switch Flashing instructions: U-Boot launches TFTP client if WPS button is pressed during power-on. Configure as follows: - Server IP: 192.168.10.100 - Filename (rename sysupgrade file to this): firmware.bin Flashing should not take more than a minute, device will reboot automatically. Signed-off-by: Thomas Aldrian <dev.aldrian@gmail.com>
-rw-r--r--target/linux/ramips/dts/mt7628an_wavlink_wl-wn578a2.dts166
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
-rw-r--r--target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds3
-rw-r--r--target/linux/ramips/mt76x8/base-files/etc/board.d/02_network6
4 files changed, 182 insertions, 3 deletions
diff --git a/target/linux/ramips/dts/mt7628an_wavlink_wl-wn578a2.dts b/target/linux/ramips/dts/mt7628an_wavlink_wl-wn578a2.dts
new file mode 100644
index 0000000000..d7238e17c6
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_wavlink_wl-wn578a2.dts
@@ -0,0 +1,166 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+ compatible = "wavlink,wl-wn578a2", "mediatek,mt7628an-soc";
+ model = "Wavlink WL-WN578A2";
+
+ aliases {
+ led-boot = &led_wps;
+ led-failsafe = &led_wps;
+ led-running = &led_wps;
+ led-upgrade = &led_wps;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ ap {
+ label = "ap";
+ gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ linux,input-type = <EV_SW>;
+ };
+
+ repeater {
+ label = "repeater";
+ gpios = <&gpio 42 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_1>;
+ linux,input-type = <EV_SW>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ wifi-high {
+ label = "green:wifi-high";
+ gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi-med {
+ label = "green:wifi-med";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi-low {
+ label = "green:wifi-low";
+ gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+ };
+
+ lan {
+ label = "green:lan";
+ gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
+ };
+
+ wan {
+ label = "green:wan";
+ gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
+ };
+
+ led_wps: wps {
+ label = "green:wps";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "i2c", "wdt", "wled_an", "p0led_an", "p1led_an",
+ "p2led_an", "p3led_an", "p4led_an", "refclk", "gpio";
+ function = "gpio";
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+};
+
+&wmac {
+ status = "okay";
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x28>;
+};
+
+&esw {
+ mediatek,portmap = <0x2f>;
+};
+
+&usbphy {
+ status = "disabled";
+};
+
+&ehci {
+ status = "disabled";
+};
+
+&ohci {
+ status = "disabled";
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index c5a0baa1cb..3ba4d658be 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -734,6 +734,16 @@ define Device/wavlink_wl-wn577a2
endef
TARGET_DEVICES += wavlink_wl-wn577a2
+define Device/wavlink_wl-wn578a2
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := Wavlink
+ DEVICE_MODEL := WL-WN578A2
+ DEVICE_ALT0_VENDOR := SilverCrest
+ DEVICE_ALT0_MODEL := SWV 733 A2
+ DEVICE_PACKAGES := kmod-mt76x0e
+endef
+TARGET_DEVICES += wavlink_wl-wn578a2
+
define Device/widora_neo-16m
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Widora
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
index fdef158ea8..e2fb44c81e 100644
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
@@ -129,7 +129,8 @@ wavlink,wl-wn575a3)
ucidef_set_led_rssi "wifi-med" "wifi-med" "green:wifi-med" "wlan1" "50" "84"
ucidef_set_led_rssi "wifi-high" "wifi-high" "green:wifi-high" "wlan1" "85" "100"
;;
-wavlink,wl-wn577a2)
+wavlink,wl-wn577a2|\
+wavlink,wl-wn578a2)
ucidef_set_led_switch "lan" "lan" "green:lan" "switch0" "0x8"
ucidef_set_led_switch "wan" "wan" "green:wan" "switch0" "0x10"
;;
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index 5ce44d0e9b..d61a60591c 100644
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -46,7 +46,8 @@ ramips_setup_interfaces()
;;
buffalo,wcr-1166ds|\
elecom,wrc-1167fs|\
- wavlink,wl-wn577a2)
+ wavlink,wl-wn577a2|\
+ wavlink,wl-wn578a2)
ucidef_add_switch "switch0" \
"3:lan" "4:wan" "6@eth0"
;;
@@ -168,7 +169,8 @@ ramips_setup_macs()
;;
cudy,wr1000|\
hilink,hlk-7688a|\
- wavlink,wl-wn577a2)
+ wavlink,wl-wn577a2|\
+ wavlink,wl-wn578a2)
wan_mac=$(mtd_get_mac_binary factory 0x2e)
label_mac=$(mtd_get_mac_binary factory 0x4)
;;