aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-09 02:05:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-09 02:05:53 +0000
commitf70512e5900733804bed0472142174f026cb21e7 (patch)
treedd0dc77e07f8fd2818ca95adc5a490e799a9fa94
parent7e534323aa6bfe64d0110c7fb2b7c4989037c5b2 (diff)
downloadupstream-f70512e5900733804bed0472142174f026cb21e7.tar.gz
upstream-f70512e5900733804bed0472142174f026cb21e7.tar.bz2
upstream-f70512e5900733804bed0472142174f026cb21e7.zip
install missing ebtables files
SVN-Revision: 3923
-rw-r--r--openwrt/package/ebtables/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/package/ebtables/Makefile b/openwrt/package/ebtables/Makefile
index 952ac29dd8..dae932ea84 100644
--- a/openwrt/package/ebtables/Makefile
+++ b/openwrt/package/ebtables/Makefile
@@ -29,7 +29,13 @@ $(PKG_BUILD_DIR)/.built:
$(IPKG_EBTABLES):
install -d -m0755 $(IDIR_EBTABLES)/etc
install -m0644 $(PKG_BUILD_DIR)/ethertypes $(IDIR_EBTABLES)/etc/
+ install -d -m0755 $(IDIR_EBTABLES)/usr/lib
+ install -m0755 $(PKG_BUILD_DIR)/lib*.so $(IDIR_EBTABLES)/usr/lib/
+ install -d -m0755 $(IDIR_EBTABLES)/usr/lib/ebtables
+ install -m0755 $(PKG_BUILD_DIR)/extensions/*.so $(IDIR_EBTABLES)/usr/lib/ebtables/
install -d -m0755 $(IDIR_EBTABLES)/usr/sbin
install -m0755 $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/
+ install -m0755 $(PKG_BUILD_DIR)/ebtables-save $(IDIR_EBTABLES)/usr/sbin/
+ install -m0755 $(PKG_BUILD_DIR)/ebtables-restore $(IDIR_EBTABLES)/usr/sbin/
$(RSTRIP) $(IDIR_EBTABLES)
$(IPKG_BUILD) $(IDIR_EBTABLES) $(PACKAGE_DIR)