aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-12-17 01:58:49 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-17 14:22:28 +0100
commitf54ac91ef5e37046e942b485e22912385251ae82 (patch)
tree1fbb8212e332c454213099845b26dd5472cbd26d
parent4472df23dae23878a75707e2803a9070ad3eb138 (diff)
downloadupstream-f54ac91ef5e37046e942b485e22912385251ae82.tar.gz
upstream-f54ac91ef5e37046e942b485e22912385251ae82.tar.bz2
upstream-f54ac91ef5e37046e942b485e22912385251ae82.zip
ar71xx/ath79: switch devices to the -ct driver and firmware
Since commit 61b5b4971e7 ("mac80211: make ath10k-ct the default ath10k") select ath10k-ct and the -ct firmwares by default. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
-rw-r--r--target/linux/ar71xx/image/generic.mk2
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk6
-rw-r--r--target/linux/ath79/image/generic.mk2
3 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 18f0379845..05428039d3 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -898,7 +898,7 @@ TARGET_DEVICES += minibox-v1
define Device/minibox-v3.2
$(Device/tplink-16mlzma)
DEVICE_TITLE := Gainstrong MiniBox V3.2
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca9887 -swconfig
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca9887-ct -swconfig
BOARDNAME := MINIBOX-V3.2
DEVICE_PROFILE := MINIBOXV32
TPLINK_HWID := 0x3C00010C
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index cb65aede5e..681c14dfb6 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -116,7 +116,7 @@ TARGET_DEVICES += ubnt_nano-m
define Device/ubnt_lap-120
$(Device/ubnt-wa)
DEVICE_TITLE := Ubiquiti LiteAP ac (LAP-120)
- DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+ DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
IMAGE_SIZE := 15744k
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
endef
@@ -125,7 +125,7 @@ TARGET_DEVICES += ubnt_lap-120
define Device/ubnt_nanostation-ac
$(Device/ubnt-wa)
DEVICE_TITLE := Ubiquiti Nanostation AC
- DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+ DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
IMAGE_SIZE := 15744k
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
endef
@@ -134,7 +134,7 @@ TARGET_DEVICES += ubnt_nanostation-ac
define Device/ubnt_nanostation-ac-loco
$(Device/ubnt-wa)
DEVICE_TITLE := Ubiquiti Nanostation AC loco
- DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+ DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
IMAGE_SIZE := 15744k
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
endef
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index cf71cb30b8..c8e1bcea4c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -212,7 +212,7 @@ TARGET_DEVICES += glinet_ar300m-nor
define Device/glinet_gl-x750
ATH_SOC := qca9531
DEVICE_TITLE := GL.iNet GL-X750
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k ath10k-firmware-qca9887
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct
IMAGE_SIZE := 16000k
endef
TARGET_DEVICES += glinet_gl-x750