aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-10-28 09:41:08 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-29 13:28:49 +0000
commitf526e85426aa8d232b167e871a0b329f0205f827 (patch)
treee114eaa4bf904d0bf4c128ad74bc4ac77cdd57b7
parentb49f2113cc750c093d3b55f228f820d8bfe029a9 (diff)
downloadupstream-f526e85426aa8d232b167e871a0b329f0205f827.tar.gz
upstream-f526e85426aa8d232b167e871a0b329f0205f827.tar.bz2
upstream-f526e85426aa8d232b167e871a0b329f0205f827.zip
base-files: hotplug-call: exit success when dir is absent
"block mount" invokes "hotplug-call mount". It emits the following error when mount is not present hotplug-call call failed Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/sbin/hotplug-call4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f105d2cd27..addbac8664 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=205
+PKG_RELEASE:=206
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/sbin/hotplug-call b/package/base-files/files/sbin/hotplug-call
index 28e957c398..f595b9e75f 100755
--- a/package/base-files/files/sbin/hotplug-call
+++ b/package/base-files/files/sbin/hotplug-call
@@ -11,8 +11,8 @@ USER=root
export PATH LOGNAME USER
export DEVICENAME="${DEVPATH##*/}"
-[ \! -z "$1" -a -d /etc/hotplug.d/$1 ] && {
+if [ \! -z "$1" -a -d /etc/hotplug.d/$1 ]; then
for script in $(ls /etc/hotplug.d/$1/* 2>&-); do (
[ -f $script ] && . $script
); done
-}
+fi