aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-22 12:01:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-22 12:01:01 +0000
commitf3e2331e18708d7080cbd12cbb967e076fd747d1 (patch)
treea4591b666464fb73af8d9de45f00110ab47842de
parent4242b42880c535007e68cc1bedbe83a4aef36814 (diff)
downloadupstream-f3e2331e18708d7080cbd12cbb967e076fd747d1.tar.gz
upstream-f3e2331e18708d7080cbd12cbb967e076fd747d1.tar.bz2
upstream-f3e2331e18708d7080cbd12cbb967e076fd747d1.zip
add a feature flag for device tree support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38893
-rw-r--r--Config.in2
-rw-r--r--include/target.mk3
-rwxr-xr-xscripts/metadata.pl1
-rw-r--r--target/Config.in3
4 files changed, 8 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index bf1e139f2e..5607e55d4d 100644
--- a/Config.in
+++ b/Config.in
@@ -204,7 +204,7 @@ menu "Target Images"
config TARGET_ROOTFS_INCLUDE_DTB
bool "Include DTB in root filesystem"
- depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
+ depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
default n if USES_UBIFS
help
Include the device tree blob file(s) in the rootfs. Typically the DTBs
diff --git a/include/target.mk b/include/target.mk
index 467ef35766..acb9adf584 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -167,6 +167,9 @@ ifeq ($(DUMP),1)
.SILENT: $(TMP_CONFIG)
.PRECIOUS: $(TMP_CONFIG)
+ ifneq ($(CONFIG_OF),)
+ FEATURES += dt
+ endif
ifneq ($(CONFIG_GENERIC_GPIO)$(CONFIG_GPIOLIB),)
FEATURES += gpio
endif
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index ddcf50bf32..135ec9a938 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -158,6 +158,7 @@ sub target_config_features(@) {
/broken/ and $ret .= "\tdepends on BROKEN\n";
/audio/ and $ret .= "\tselect AUDIO_SUPPORT\n";
/display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
+ /dt/ and $ret .= "\tselect USES_DEVICETREE\n";
/gpio/ and $ret .= "\tselect GPIO_SUPPORT\n";
/pci/ and $ret .= "\tselect PCI_SUPPORT\n";
/pcie/ and $ret .= "\tselect PCIE_SUPPORT\n";
diff --git a/target/Config.in b/target/Config.in
index 7f694e4c8b..bb442025f5 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -39,6 +39,9 @@ config RTC_SUPPORT
config BIG_ENDIAN
bool
+config USES_DEVICETREE
+ bool
+
config USES_INITRAMFS
bool