aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-06-15 18:07:32 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-06-18 10:39:35 +0800
commitf334a0cdb8498dfd2bbb780245e4e0ed0d103ece (patch)
tree2e563f1bebf93593ecc3f9e045ca6f219457b573
parent3ccca56eb0a44bb72561c6381faf63564eeec858 (diff)
downloadupstream-f334a0cdb8498dfd2bbb780245e4e0ed0d103ece.tar.gz
upstream-f334a0cdb8498dfd2bbb780245e4e0ed0d103ece.tar.bz2
upstream-f334a0cdb8498dfd2bbb780245e4e0ed0d103ece.zip
base-files: allocate uid/gid starting from 65536
There already exist static assignment of uid/gid 65533 in packages feed and we have nobody/nogroup taking 65534 as their ids. Let's change the pid of dynamic assignment to start from 65536 so that the two assignment scheme will not collide with each other While at it, fix the scan command checking existence of uid/gid Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/lib/functions.sh8
2 files changed, 5 insertions, 5 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index c669ff0ac6..54c157611f 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=173
+PKG_RELEASE:=174
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/functions.sh b/package/base-files/files/lib/functions.sh
index 2b6415a200..81ef84b8ef 100755
--- a/package/base-files/files/lib/functions.sh
+++ b/package/base-files/files/lib/functions.sh
@@ -306,8 +306,8 @@ group_add_next() {
gid=$(grep -s "^${1}:" ${IPKG_INSTROOT}/etc/group | cut -d: -f3)
[ -n "$gid" ] && return $gid
gids=$(cat ${IPKG_INSTROOT}/etc/group | cut -d: -f3)
- gid=100
- while [ -n "$(echo $gids | grep $gid)" ] ; do
+ gid=65536
+ while [ -n "$(echo "$gids" | grep "^$gid$")" ] ; do
gid=$((gid + 1))
done
group_add $1 $gid
@@ -334,8 +334,8 @@ user_add() {
local rc
[ -z "$uid" ] && {
uids=$(cat ${IPKG_INSTROOT}/etc/passwd | cut -d: -f3)
- uid=100
- while [ -n "$(echo $uids | grep $uid)" ] ; do
+ uid=65536
+ while [ -n "$(echo "$uids" | grep "^$uid$")" ] ; do
uid=$((uid + 1))
done
}