aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Roederer <devel-sven@geroedel.de>2021-05-07 21:35:20 +0200
committerBaptiste Jonglez <git@bitsofnetworks.org>2021-05-14 22:52:40 +0200
commitf25dc537238673c641eca6e7ce566476b839c46a (patch)
tree1080ef871f31d3d14d76f6f6b64c469f0b5247db
parentc6ce0411e190885be9f9420c1705bd4cee32bccb (diff)
downloadupstream-f25dc537238673c641eca6e7ce566476b839c46a.tar.gz
upstream-f25dc537238673c641eca6e7ce566476b839c46a.tar.bz2
upstream-f25dc537238673c641eca6e7ce566476b839c46a.zip
imagebuilder: unset BINARY_FOLDER and DOWNLOAD_FOLDER in final archive
Using these config-options to customize the folders used at build-time makes these folder settings appear in generated archive. This causes the imagebuilder to be not portable, as it's going to use the build-time folders on the new systems. Errors look like: mkdir: cannot create directory '/mnt/build': Permission denied Makefile:116: recipe for target '_call_image' failed make[2]: *** [_call_image] Error 1 Makefile:241: recipe for target 'image' failed make[1]: *** [image] Error 2 The build-time settings of these folders are passed into the archives via .config file. The expected behavior is that after unpacking the imagebuilder acts like these settings have their defaults, using intree folders. So unset the build-time settings. Signed-off-by: Sven Roederer <devel-sven@geroedel.de> (cherry picked from commit 6967903b01ea9f7c9f70d0185c3da276801dd78f)
-rw-r--r--target/imagebuilder/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index f9c08776a8..0580e41c57 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -29,6 +29,8 @@ $(BIN_DIR)/$(IB_NAME).tar.xz: clean
mkdir -p $(IB_KDIR) $(IB_LDIR) $(PKG_BUILD_DIR)/staging_dir/host/lib \
$(PKG_BUILD_DIR)/target $(PKG_BUILD_DIR)/scripts $(IB_DTSDIR)
-cp $(TOPDIR)/.config $(PKG_BUILD_DIR)/.config
+ $(SED) 's/^CONFIG_BINARY_FOLDER=.*/# CONFIG_BINARY_FOLDER is not set/' $(PKG_BUILD_DIR)/.config
+ $(SED) 's/^CONFIG_DOWNLOAD_FOLDER=.*/# CONFIG_DOWNLOAD_FOLDER is not set/' $(PKG_BUILD_DIR)/.config
$(CP) -L \
$(INCLUDE_DIR) $(SCRIPT_DIR) \
$(TOPDIR)/rules.mk \