aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-01-12 11:52:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-01-12 11:52:40 +0000
commitf126298a7c78c174507b01b518e613a62341b760 (patch)
tree2910cf0d69a8793857bad55fb159ddbdc2277e4f
parent719b57cbc125a7cf926f2ea8c3b0a1f114a8c0f2 (diff)
downloadupstream-f126298a7c78c174507b01b518e613a62341b760.tar.gz
upstream-f126298a7c78c174507b01b518e613a62341b760.tar.bz2
upstream-f126298a7c78c174507b01b518e613a62341b760.zip
rpcd: build, uci and session api fixes
- fix CMakeFile to support rpcd out of tree builds - fix a possible file descriptor leak in the session deserialization code - add uci.state call which is equivalent to uci -P /var/state get ... - make uci.changes "config" argument optional to allow listing all deltas in one go - fix inverted check in uci.commit and uci.revert, resulting in eroorneous permission denied responses - only trigger config change events if libuci was able to parse the config - rename misleading "commit" argument of uci.apply to the more appropriate name "rollback" Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 39224
-rw-r--r--package/system/rpcd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index ef663a297b..316b5d69c0 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rpcd
-PKG_VERSION:=2013-09-29
+PKG_VERSION:=2014-01-12
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/rpcd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)
-PKG_SOURCE_VERSION:=095b1058c8cb1147d11028974be4067009bcfd67
+PKG_SOURCE_VERSION:=0c4e97b4e7b440d02aec3aff9d06c9bc93717571
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>