aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-09-01 19:32:36 -0700
committerHans Dedecker <dedeckeh@gmail.com>2021-09-05 21:28:43 +0200
commiteef7f9ea37366c93039b386ca8e438b26a199214 (patch)
treee164a49566ad0f31bd1f59b4b83ea335d6ac4541
parentf431f2c4b654c04d9765b2aabe57a907b9c7b3ea (diff)
downloadupstream-eef7f9ea37366c93039b386ca8e438b26a199214.tar.gz
upstream-eef7f9ea37366c93039b386ca8e438b26a199214.tar.bz2
upstream-eef7f9ea37366c93039b386ca8e438b26a199214.zip
tools/cmake: update to 3.21.2
Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--tools/cmake/Makefile4
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch2
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index fc7926fda5..49dc61ee34 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,14 +7,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.20.3
+PKG_VERSION:=3.21.2
PKG_RELEASE:=1
PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/Kitware/CMake/releases/download/v$(PKG_VERSION)/ \
https://cmake.org/files/v3.19/
-PKG_HASH:=4d008ac3461e271fcfac26a05936f77fc7ab64402156fb371d41284851a651b8
+PKG_HASH:=94275e0b61c84bb42710f5320a23c6dcb2c6ee032ae7d2a616f53f68b3d21659
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index 1095a4f8ac..97ef5ceb00 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -508,6 +508,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -528,6 +528,14 @@ if(CMAKE_USE_OPENSSL)
endif()
set(SSL_ENABLED ON)
set(USE_OPENSSL ON)
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 512765c5af..3822cba166 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1397,7 +1397,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1420,7 +1420,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if test "x${cmake_parallel_make}" != "x"; then