aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-10-09 17:18:30 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-10-09 17:18:30 +0000
commitec7ce598efe6ae0a9bd27a94935d346c7a760580 (patch)
treeccf3a3089ef3149ad80e9e25908a552e9a88fc19
parente5939821bbc5d2820e02b9a4327ac0fd155b03a3 (diff)
downloadupstream-ec7ce598efe6ae0a9bd27a94935d346c7a760580.tar.gz
upstream-ec7ce598efe6ae0a9bd27a94935d346c7a760580.tar.bz2
upstream-ec7ce598efe6ae0a9bd27a94935d346c7a760580.zip
Port kmod-ipip to the new module layout
SVN-Revision: 4991
-rw-r--r--openwrt/include/modules-2.6.mk4
-rw-r--r--openwrt/package/kernel/modules.mk9
2 files changed, 9 insertions, 4 deletions
diff --git a/openwrt/include/modules-2.6.mk b/openwrt/include/modules-2.6.mk
index 950ff56786..fecaaba604 100644
--- a/openwrt/include/modules-2.6.mk
+++ b/openwrt/include/modules-2.6.mk
@@ -15,10 +15,6 @@ $(eval $(call KMOD_template,ATM,atm,\
$(MODULES_DIR)/kernel/drivers/atm/atmtcp.ko \
,CONFIG_ATM,,50,atm))
-$(eval $(call KMOD_template,IPIP,ipip,\
- $(MODULES_DIR)/kernel/net/ipv4/ipip.ko \
-,CONFIG_NET_IPIP,,60,ipip))
-
# Block devices
$(eval $(call KMOD_template,LOOP,loop,\
diff --git a/openwrt/package/kernel/modules.mk b/openwrt/package/kernel/modules.mk
index 17ad12b350..2ce3ba91ed 100644
--- a/openwrt/package/kernel/modules.mk
+++ b/openwrt/package/kernel/modules.mk
@@ -303,6 +303,15 @@ define KernelPackage/ebtables
endef
$(eval $(call KernelPackage,ebtables))
+define KernelPackage/ipip
+ TITLE:=IP in IP encapsulation support
+ DESCRIPTION:=\
+ Kernel modules for IP in IP encapsulation
+ FILES:=$(MODULES_DIR)/kernel/net/ipv4/ipip.$(LINUX_KMOD_SUFFIX)
+ KCONFIG:=$(CONFIG_NET_IPIP)
+endef
+$(eval $(call KernelPackage,ipip))
+
define KernelPackage/ipv6
TITLE:=IPv6 support