aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-11-25 18:33:33 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-11-25 18:33:33 +0000
commitea36d4dd38538fd811a8f02b45ec93109f2b8220 (patch)
treeb4434cb732b693e43abc16129109e40814cdcaa6
parentfdd05db0d82444904825dfd6b0abdc5f7d37cb5a (diff)
downloadupstream-ea36d4dd38538fd811a8f02b45ec93109f2b8220.tar.gz
upstream-ea36d4dd38538fd811a8f02b45ec93109f2b8220.tar.bz2
upstream-ea36d4dd38538fd811a8f02b45ec93109f2b8220.zip
fix lzma uImage generation
SVN-Revision: 13351
-rw-r--r--target/linux/avr32/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index c74efbe1df..692c325b5e 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -25,7 +25,7 @@ endef
define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
- $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ $(STAGING_DIR_HOST)/bin/lzma e $(LINUX_DIR)/arch/avr32/boot/images/vmlinux.bin $(KDIR)/vmlinux.lzma
mkimage -A avr32 -O linux -T kernel -a 0x10000000 -C lzma \
-e 0x90000000 \
-n 'OpenWrt Linux-$(LINUX_VERSION)' \