aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-05-30 07:20:19 -0400
committerPetr Štetiar <ynezz@true.cz>2023-06-12 22:10:24 +0200
commitea22a1f4da2ee98cd8354acc61840199814dfb6d (patch)
tree67a26210a6e7ef7ef3ad8ac12e9a56151307053f
parente972e4f2a9ecbb65b826f53b890e4705c6034f43 (diff)
downloadupstream-ea22a1f4da2ee98cd8354acc61840199814dfb6d.tar.gz
upstream-ea22a1f4da2ee98cd8354acc61840199814dfb6d.tar.bz2
upstream-ea22a1f4da2ee98cd8354acc61840199814dfb6d.zip
host-build: add support for a stampfile per installed binary
Some individual build items install a group of programs instead of a program matching the name of the build item. Add support for installing stampfiles for each of the programs installed by that build item, which will allow more control and awareness of what is installed by the rest of the build system, if, for example, prereq symlink checks are looking for the same program which is built already. Signed-off-by: Michael Pratt <mcpratt@pm.me> (cherry picked from commit 84f7a45e9e83339d84bcc15f06259b1064cb961a)
-rw-r--r--include/host-build.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 7485f91e42..dba6b819da 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -26,6 +26,7 @@ HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
HOST_BUILD_PREFIX?=$(if $(IS_PACKAGE_BUILD),$(STAGING_DIR_HOSTPKG),$(STAGING_DIR_HOST))
HOST_STAMP_INSTALLED:=$(HOST_BUILD_PREFIX)/stamp/.$(PKG_NAME)_installed
+HOST_STAMP_PROGRAMS:=$(foreach program,$(PKG_PROGRAMS),$(subst $(PKG_NAME),$(program),$(HOST_STAMP_INSTALLED)) )
override MAKEFLAGS=
@@ -172,7 +173,7 @@ ifndef DUMP
$(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
mkdir -p $$(shell dirname $$@)
touch $(HOST_STAMP_BUILT)
- touch $$@
+ touch $$@ $(HOST_STAMP_PROGRAMS)
$(call DefaultTargets,$(patsubst %,host-%,$(DEFAULT_SUBDIR_TARGETS)))
ifndef STAMP_BUILT
@@ -187,7 +188,7 @@ ifndef DUMP
$(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
$(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
- $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
+ $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_PROGRAMS)
host-install: host-compile
host-clean-build: FORCE
@@ -196,7 +197,7 @@ ifndef DUMP
host-clean: host-clean-build
$(call Host/Clean)
- rm -rf $(HOST_STAMP_INSTALLED)
+ rm -rf $(HOST_STAMP_INSTALLED) $(HOST_STAMP_PROGRAMS)
ifneq ($(CONFIG_AUTOREMOVE),)
host-compile: