aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-24 14:25:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-24 14:25:55 +0000
commite9a0d8517b43b6fae37bb593de36694b68efb713 (patch)
tree769a35002e3fc607c4c7a67e8ae267e76ab7fc5c
parenta39e9d3a27f650dc01478bfdeda138e1a08eda01 (diff)
downloadupstream-e9a0d8517b43b6fae37bb593de36694b68efb713.tar.gz
upstream-e9a0d8517b43b6fae37bb593de36694b68efb713.tar.bz2
upstream-e9a0d8517b43b6fae37bb593de36694b68efb713.zip
add microcom
SVN-Revision: 1050
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile1
-rw-r--r--openwrt/package/microcom/Config.in6
-rw-r--r--openwrt/package/microcom/Makefile43
-rw-r--r--openwrt/package/microcom/ipkg/microcom.control6
5 files changed, 57 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 7e81af5a70..9fe2faf3b4 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -109,6 +109,7 @@ source "package/uclibc++/Config.in"
source "package/zlib/Config.in"
comment "Utilities ---"
+source "package/microcom/Config.in"
source "package/usbutils/Config.in" # lsusb
source "package/setserial/Config.in"
source "package/strace/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 5dd8432b6c..8a5cd0619d 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -50,6 +50,7 @@ package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
package-$(BR2_PACKAGE_LZO) += lzo
package-$(BR2_PACKAGE_MARADNS) += maradns
package-$(BR2_PACKAGE_MATRIXSSL) += matrixssl
+package-$(BR2_PACKAGE_MICROCOM) += microcom
package-$(BR2_PACKAGE_MICROPERL) += microperl
package-$(BR2_PACKAGE_MONIT) += monit
package-$(BR2_PACKAGE_MYSQL) += mysql
diff --git a/openwrt/package/microcom/Config.in b/openwrt/package/microcom/Config.in
new file mode 100644
index 0000000000..29c4f5b33e
--- /dev/null
+++ b/openwrt/package/microcom/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_MICROCOM
+ tristate "microcom (serial terminal)"
+ default m
+ help
+ microcom is a minicom-like serial terminal emulator with scripting
+ support.
diff --git a/openwrt/package/microcom/Makefile b/openwrt/package/microcom/Makefile
new file mode 100644
index 0000000000..b6b2ac1e22
--- /dev/null
+++ b/openwrt/package/microcom/Makefile
@@ -0,0 +1,43 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=microcom
+PKG_VERSION:=1.02
+PKG_FILEVERSION:=102
+PKG_RELEASE:=1
+PKG_MD5SUM:=c7817035dc41cb02e7cfb565cf9b7401
+
+PKG_SOURCE_URL:=http://microcom.port5.com/
+PKG_SOURCE:=m$(PKG_FILEVERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MICROCOM,microcom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.prepared:
+ rm -rf $(PKG_BUILD_DIR)
+ mkdir -p $(PKG_BUILD_DIR)
+ # the .tar.gz is different - no subdirectory, so do this manually
+ $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS) -
+ touch $@
+
+$(PKG_BUILD_DIR)/.configured:
+ cp $(PKG_BUILD_DIR)/Makefile $(PKG_BUILD_DIR)/Makefile.tmp
+ sed 's~gcc~$$(CC)~' $(PKG_BUILD_DIR)/Makefile.tmp > $(PKG_BUILD_DIR)/Makefile
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR) CC=$(TARGET_CC)
+ touch $@
+
+$(IPKG_MICROCOM):
+ install -d -m0755 $(IDIR_MICROCOM)/usr/bin
+ install -m0755 $(PKG_BUILD_DIR)/microcom $(IDIR_MICROCOM)/usr/bin
+ $(RSTRIP) $(IDIR_MICROCOM)
+ $(IPKG_BUILD) $(IDIR_MICROCOM) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/microcom/ipkg/microcom.control b/openwrt/package/microcom/ipkg/microcom.control
new file mode 100644
index 0000000000..002abe418d
--- /dev/null
+++ b/openwrt/package/microcom/ipkg/microcom.control
@@ -0,0 +1,6 @@
+Package: microcom
+Priority: optional
+Section: console
+Maintainer: Georg Lukas <georg@boerde.de>
+Source: buildroot internal
+Description: serial terminal