aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-09-28 11:12:21 -1000
committerDaniel Golle <daniel@makrotopia.org>2019-09-29 00:08:20 +0200
commite78c1baa9f52d2137303c440e11570ca2a484aab (patch)
treed20ad94dcfc778a4f79a9a014b94405917e254da
parent400e56d22c9faddccfb429f16885536bcc31f06d (diff)
downloadupstream-e78c1baa9f52d2137303c440e11570ca2a484aab.tar.gz
upstream-e78c1baa9f52d2137303c440e11570ca2a484aab.tar.bz2
upstream-e78c1baa9f52d2137303c440e11570ca2a484aab.zip
rules: allow arbitrary log destination
Add option BUILD_LOG_DIR to menuconfig to change log destination. The mix-up of *DIR* and *FOLDER* is confusing however. Signed-off-by: Paul Spooren <mail@aparcar.org>
-rw-r--r--config/Config-devel.in7
-rw-r--r--rules.mk2
2 files changed, 8 insertions, 1 deletions
diff --git a/config/Config-devel.in b/config/Config-devel.in
index fd7c3ead1e..70ec0ce9a7 100644
--- a/config/Config-devel.in
+++ b/config/Config-devel.in
@@ -105,6 +105,13 @@ menuconfig DEVEL
help
If enabled, log files will be written to the ./log directory.
+ config BUILD_LOG_DIR
+ string "Log folder" if DEVEL
+ default ""
+ help
+ Store build logs in this directory.
+ If not set, uses './logs'
+
config SRC_TREE_OVERRIDE
bool "Enable package source tree override" if DEVEL
help
diff --git a/rules.mk b/rules.mk
index 80cb3d63f4..b140fbca70 100644
--- a/rules.mk
+++ b/rules.mk
@@ -159,7 +159,7 @@ TARGET_ROOTFS_DIR?=$(if $(call qstrip,$(CONFIG_TARGET_ROOTFS_DIR)),$(call qstrip
TARGET_DIR:=$(TARGET_ROOTFS_DIR)/root-$(BOARD)
STAGING_DIR_ROOT:=$(STAGING_DIR)/root-$(BOARD)
STAGING_DIR_IMAGE:=$(STAGING_DIR)/image
-BUILD_LOG_DIR:=$(TOPDIR)/logs
+BUILD_LOG_DIR:=$(if $(call qstrip,$(CONFIG_BUILD_LOG_DIR)),$(call qstrip,$(CONFIG_BUILD_LOG_DIR)),$(TOPDIR)/logs)
PKG_INFO_DIR := $(STAGING_DIR)/pkginfo
BUILD_DIR_HOST:=$(if $(IS_PACKAGE_BUILD),$(BUILD_DIR_BASE)/hostpkg,$(BUILD_DIR_BASE)/host)