aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-12-27 02:32:39 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-27 14:06:38 +0100
commite67da3443168fa6b6727cd81a35d559be77d6b4c (patch)
tree601ffc3a594a02a7e2102852e8c907aa26e69927
parent1724d4e9ed7716a5444eca42adf045c2f3afc554 (diff)
downloadupstream-e67da3443168fa6b6727cd81a35d559be77d6b4c.tar.gz
upstream-e67da3443168fa6b6727cd81a35d559be77d6b4c.tar.bz2
upstream-e67da3443168fa6b6727cd81a35d559be77d6b4c.zip
ath79: add support for devolo WiFi pro 1750c
Hardware -------- CPU: Qualcomm Atheros QCA9558 RAM: 128M DDR2 FLASH: 16MiB ETH: 1x Atheros AR8035 (PoE in) WiFi2: QCA9558 3T3R WiFi5: QCA9880 3T3R BTN: 1x Reset LED: 1x LED blue 1x LED red BEEP: 1x GPIO attached piezo beeper UART: 3.3V GND TX RX (115200-N-8) (3.3V is square pad) Header is located next to reset-button There is also a Micro-B USB-port present but this only seems to be a dummy as the circuit next to it is not present (at least in my unit). It is also not mentioned in the devolo manual. Installation ------------ Make sure you set a password for the root user as prompted on first setup! 1. Upload OpenWRT sysupgrade image via SSH to the device. Use /tmp as the destination folder on the device. User is root, password the one set in the web interface. 2. Install OpenWRT with > sysupgrade -n -F /tmp/<openwrt-image-name> Signed-off-by: David Bauer <mail@david-bauer.net>
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata3
-rw-r--r--target/linux/ath79/dts/qca9558_devolo_dvl1750c.dts46
-rw-r--r--target/linux/ath79/image/generic.mk8
4 files changed, 57 insertions, 1 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index b2c7762bb5..64067c8da7 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -10,6 +10,7 @@ ath79_setup_interfaces()
case "$board" in
avm,fritz300e|\
+ devolo,dvl1750c|\
ocedo,koala|\
ocedo,raccoon|\
pcs,cap324|\
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index deaac72174..b83f3c0b94 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -87,7 +87,8 @@ board=$(board_name)
case "$FIRMWARE" in
"ath10k/cal-pci-0000:00:00.0.bin")
case $board in
- devolo,dvl1200e)
+ devolo,dvl1200e|\
+ devolo,dvl1750c)
ath10kcal_extract "art" 20480 2116
ath10kcal_patch_mac_crc $(macaddr_add $(mtd_get_mac_binary art 0) -1)
;;
diff --git a/target/linux/ath79/dts/qca9558_devolo_dvl1750c.dts b/target/linux/ath79/dts/qca9558_devolo_dvl1750c.dts
new file mode 100644
index 0000000000..b5a2954406
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_devolo_dvl1750c.dts
@@ -0,0 +1,46 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9558_devolo_dvl1xxx.dtsi"
+
+/ {
+ compatible = "devolo,dvl1750c", "qca,qca9557";
+ model = "devolo WiFi pro 1750c";
+
+ aliases {
+ led-boot = &status_blue;
+ led-failsafe = &status_red;
+ led-running = &status_blue;
+ led-upgrade = &status_red;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ status_blue: status_blue {
+ label = "dvl1750c:blue:status";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ status_red: status_red {
+ label = "dvl1750c:red:status";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ beeper {
+ compatible = "gpio-beeper";
+ gpios = <&gpio 21 GPIO_ACTIVE_HIGH>;
+ };
+};
+
+&gmac_config {
+ rxdv-delay = <3>;
+ rxd-delay = <3>;
+ txen-delay = <3>;
+ txd-delay = <3>;
+};
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ef8cf170de..b2f83ba58c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -146,6 +146,14 @@ define Device/devolo_dvl1200e
endef
TARGET_DEVICES += devolo_dvl1200e
+define Device/devolo_dvl1750c
+ ATH_SOC := qca9558
+ DEVICE_TITLE := devolo WiFi pro 1750c
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1750c
+
define Device/dlink_dir-825-b1
ATH_SOC := ar7161
DEVICE_TITLE := D-LINK DIR-825 B1