aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-02-25 11:24:12 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-02-25 17:34:25 +0100
commite2ba7a4b4707b8e24b1b28abbc17313b98362fa2 (patch)
treebe62b3254efabe377d0148be1ae4d85840dac6b0
parent1be6ff6dc0ab53d2191c49c32cae7f6f9aadd14d (diff)
downloadupstream-e2ba7a4b4707b8e24b1b28abbc17313b98362fa2.tar.gz
upstream-e2ba7a4b4707b8e24b1b28abbc17313b98362fa2.tar.bz2
upstream-e2ba7a4b4707b8e24b1b28abbc17313b98362fa2.zip
kernel: bump 4.9 to 4.9.160
Refreshed all patches. Compile-tested on: ar71xx Runtime-tested on: ar71xx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/backport-4.9/041-mm-rename-__alloc_page_frag-to-page_frag_alloc-and-_.patch6
-rw-r--r--target/linux/generic/hack-4.9/721-phy_packets.patch2
-rw-r--r--target/linux/ixp4xx/patches-4.9/600-skb_avoid_dmabounce.patch2
-rw-r--r--target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch14
5 files changed, 14 insertions, 14 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 98cf7cafe4..311922fab6 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,11 +2,11 @@
LINUX_RELEASE?=1
-LINUX_VERSION-4.9 = .159
LINUX_VERSION-4.14 = .102
+LINUX_VERSION-4.9 = .160
-LINUX_KERNEL_HASH-4.9.159 = 9f9df13168a090d12314e2e8dac040e71ce3f2ed89eafbece2b14dabb6771742
LINUX_KERNEL_HASH-4.14.102 = d8a982cfa2804edc2ae9d20792ab0e3897f3976ced5632f2392c2e1918562501
+LINUX_KERNEL_HASH-4.9.160 = c09af067af62d299f5e33c279968de58c88fb7c59bd05e8f3bb460f611f60515
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/backport-4.9/041-mm-rename-__alloc_page_frag-to-page_frag_alloc-and-_.patch b/target/linux/generic/backport-4.9/041-mm-rename-__alloc_page_frag-to-page_frag_alloc-and-_.patch
index d1da94b4e6..facc43004e 100644
--- a/target/linux/generic/backport-4.9/041-mm-rename-__alloc_page_frag-to-page_frag_alloc-and-_.patch
+++ b/target/linux/generic/backport-4.9/041-mm-rename-__alloc_page_frag-to-page_frag_alloc-and-_.patch
@@ -108,7 +108,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
local_irq_restore(flags);
return data;
}
-@@ -391,7 +391,7 @@ static void *__napi_alloc_frag(unsigned
+@@ -393,7 +393,7 @@ static void *__napi_alloc_frag(unsigned
{
struct napi_alloc_cache *nc = this_cpu_ptr(&napi_alloc_cache);
@@ -117,7 +117,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
}
void *napi_alloc_frag(unsigned int fragsz)
-@@ -441,7 +441,7 @@ struct sk_buff *__netdev_alloc_skb(struc
+@@ -445,7 +445,7 @@ struct sk_buff *__netdev_alloc_skb(struc
local_irq_save(flags);
nc = this_cpu_ptr(&netdev_alloc_cache);
@@ -126,7 +126,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
pfmemalloc = nc->pfmemalloc;
local_irq_restore(flags);
-@@ -505,7 +505,7 @@ struct sk_buff *__napi_alloc_skb(struct
+@@ -509,7 +509,7 @@ struct sk_buff *__napi_alloc_skb(struct
if (sk_memalloc_socks())
gfp_mask |= __GFP_MEMALLOC;
diff --git a/target/linux/generic/hack-4.9/721-phy_packets.patch b/target/linux/generic/hack-4.9/721-phy_packets.patch
index 9bc5b01776..d22c873032 100644
--- a/target/linux/generic/hack-4.9/721-phy_packets.patch
+++ b/target/linux/generic/hack-4.9/721-phy_packets.patch
@@ -136,7 +136,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#include <net/protocol.h>
#include <net/dst.h>
-@@ -529,6 +530,22 @@ skb_fail:
+@@ -533,6 +534,22 @@ skb_fail:
}
EXPORT_SYMBOL(__napi_alloc_skb);
diff --git a/target/linux/ixp4xx/patches-4.9/600-skb_avoid_dmabounce.patch b/target/linux/ixp4xx/patches-4.9/600-skb_avoid_dmabounce.patch
index 046ec4e8f3..cdd9fde8f0 100644
--- a/target/linux/ixp4xx/patches-4.9/600-skb_avoid_dmabounce.patch
+++ b/target/linux/ixp4xx/patches-4.9/600-skb_avoid_dmabounce.patch
@@ -10,7 +10,7 @@
/* Get the HEAD */
skb = kmem_cache_alloc_node(cache, gfp_mask & ~__GFP_DMA, node);
-@@ -1224,6 +1227,10 @@ int pskb_expand_head(struct sk_buff *skb
+@@ -1228,6 +1231,10 @@ int pskb_expand_head(struct sk_buff *skb
if (skb_shared(skb))
BUG();
diff --git a/target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch b/target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch
index cc66e7f3e1..c5b06ec7f4 100644
--- a/target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch
@@ -338,7 +338,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
/* register save area for suspend/resume */
--- a/include/linux/netdev_features.h
+++ b/include/linux/netdev_features.h
-@@ -74,6 +74,7 @@ enum {
+@@ -76,6 +76,7 @@ enum {
NETIF_F_BUSY_POLL_BIT, /* Busy poll */
NETIF_F_HW_TC_BIT, /* Offload TC infrastructure */
@@ -346,14 +346,14 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
/*
* Add your fresh new feature above and remember to update
-@@ -136,6 +137,7 @@ enum {
+@@ -138,6 +139,7 @@ enum {
#define NETIF_F_HW_L2FW_DOFFLOAD __NETIF_F(HW_L2FW_DOFFLOAD)
#define NETIF_F_BUSY_POLL __NETIF_F(BUSY_POLL)
#define NETIF_F_HW_TC __NETIF_F(HW_TC)
+#define NETIF_F_HW_ACCEL_MQ __NETIF_F(HW_ACCEL_MQ)
- #define for_each_netdev_feature(mask_addr, bit) \
- for_each_set_bit(bit, (unsigned long *)mask_addr, NETDEV_FEATURE_COUNT)
+ /* Finds the next feature with the highest number of the range of start till 0.
+ */
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -1512,6 +1512,8 @@ enum netdev_priv_flags {
@@ -444,7 +444,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
return -ENODEV;
--- a/net/core/skbuff.c
+++ b/net/core/skbuff.c
-@@ -842,6 +842,32 @@ void napi_consume_skb(struct sk_buff *sk
+@@ -846,6 +846,32 @@ void napi_consume_skb(struct sk_buff *sk
}
EXPORT_SYMBOL(napi_consume_skb);
@@ -477,7 +477,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
/* Make sure a field is enclosed inside headers_start/headers_end section */
#define CHECK_SKB_FIELD(field) \
BUILD_BUG_ON(offsetof(struct sk_buff, field) < \
-@@ -1075,7 +1101,7 @@ static void skb_headers_offset_update(st
+@@ -1079,7 +1105,7 @@ static void skb_headers_offset_update(st
skb->inner_mac_header += off;
}
@@ -486,7 +486,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
{
__copy_skb_header(new, old);
-@@ -1083,6 +1109,7 @@ static void copy_skb_header(struct sk_bu
+@@ -1087,6 +1113,7 @@ static void copy_skb_header(struct sk_bu
skb_shinfo(new)->gso_segs = skb_shinfo(old)->gso_segs;
skb_shinfo(new)->gso_type = skb_shinfo(old)->gso_type;
}