aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Roederer <devel-sven@geroedel.de>2019-03-25 00:03:19 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-04-13 14:39:59 +0200
commite0d98e120a94b75f63066d7abc6a392996ccb284 (patch)
tree9cbc153a69460881da2777d44592b4a81718efe9
parent9385ff654e4d9ef1270b2cbb411be3754513c9ed (diff)
downloadupstream-e0d98e120a94b75f63066d7abc6a392996ccb284.tar.gz
upstream-e0d98e120a94b75f63066d7abc6a392996ccb284.tar.bz2
upstream-e0d98e120a94b75f63066d7abc6a392996ccb284.zip
ath79: add TP-Link WR842N v3
This adds support for the TP-Link WR842N v3 which is already supported on ar71xx target (0b45bec22c59cc6e6b2fa71dc9a88386c5587132). Specification: * SoC: QCA9533 ver 2 rev 0 * 16 MB Flash (gd25q128) * 64 MB RAM * 1 WAN 10/100 MBit/s (blue connector) * 4 LAN 10/100 MBit/s (AR8229; 4 ports; yellow connectors) * Atheros AR9531 (2,4GHz, two fixed antennas) * USB * Reset / WPS button * WiFi button (rf kill) * 8 green leds; 1 red/green led * serial console (115200 8N1, according to the OpenWrt-wiki some soldering is needed) Installation: * flash via vendor WebUI (the filename must not exceed certain length) * sysupgrade from installed OpenWrt (also ar71xx) Thanks to Holger Drefs for providing the hardware Tested-by: @kofec (github) Signed-off-by: Sven Roederer <devel-sven@geroedel.de>
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/dts/qca9533_tplink_tl-wr842n-v3.dts168
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk10
4 files changed, 181 insertions, 1 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index af26425da2..9c353baabe 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -163,7 +163,8 @@ tplink,tl-wr842n-v2)
ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
;;
tplink,tl-wr841-v9|\
-tplink,tl-wr841-v11)
+tplink,tl-wr841-v11|\
+tplink,tl-wr842n-v3)
ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth0"
ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
ucidef_set_led_switch "lan2" "LAN2" "tp-link:green:lan2" "switch0" "0x08"
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 2f4fb62a5f..f877669f98 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -180,6 +180,7 @@ ath79_setup_interfaces()
tplink,tl-mr3420-v1|\
tplink,tl-wr841-v9|\
tplink,tl-wr841-v11|\
+ tplink,tl-wr842n-v3|\
ubnt,airrouter)
ucidef_set_interface_wan "eth0"
ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr842n-v3.dts b/target/linux/ath79/dts/qca9533_tplink_tl-wr842n-v3.dts
new file mode 100644
index 0000000000..64be0744b2
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_tplink_tl-wr842n-v3.dts
@@ -0,0 +1,168 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+ compatible = "tplink,tl-wr842n-v3", "qca,qca9533";
+ model = "TP-Link TL-WR842N v3";
+
+ aliases {
+ led-boot = &qss_led;
+ led-failsafe = &qss_led;
+ led-running = &qss_led;
+ led-upgrade = &qss_led;
+ };
+
+ gpio_leds: leds {
+ compatible = "gpio-leds";
+
+ system: power {
+ label = "tp-link:green:power";
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wifi {
+ label = "tp-link:green:wlan";
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ qss_led: qss {
+ label = "tp-link:green:qss";
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_green {
+ label = "tp-link:green:wan";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_red {
+ label = "tp-link:red:wan";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ };
+
+ lan1 {
+ label = "tp-link:green:lan1";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ };
+
+ lan2 {
+ label = "tp-link:green:lan2";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ };
+
+ lan3 {
+ label = "tp-link:green:lan3";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ };
+
+ lan4 {
+ label = "tp-link:green:lan4";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+
+ usb {
+ label = "tp-link:green:usb";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "usbport";
+ trigger-sources = <&hub_port>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "Reset button";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ rfkill {
+ label = "RFKILL button";
+ linux,code = <KEY_RFKILL>;
+ gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&usb0 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ hub_port: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "tplink,firmware";
+ label = "firmware";
+ reg = <0x020000 0xfd0000>;
+ };
+
+ art: partition@ff0000 {
+ label = "ART";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&eth1 {
+ mtd-mac-address = <&uboot 0x1fc00>;
+};
+
+&eth0 {
+ status = "okay";
+ phy-handle = <&swphy4>;
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+ mtd-mac-address-increment = <1>;
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&uboot 0x1fc00>;
+};
+
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index ecc34b88e0..6853f12341 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -243,6 +243,16 @@ define Device/tplink_tl-wr842n-v2
endef
TARGET_DEVICES += tplink_tl-wr842n-v2
+define Device/tplink_tl-wr842n-v3
+ $(Device/tplink-16mlzma)
+ ATH_SOC := qca9533
+ DEVICE_TITLE := TP-Link TL-WR842N v3
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x8420003
+ SUPPORTED_DEVICES += tl-wr842n-v3
+endef
+TARGET_DEVICES += tplink_tl-wr842n-v3
+
define Device/tplink_tl-wr1043nd-v2
$(Device/tplink-8mlzma)
ATH_SOC := qca9558