aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-01-28 23:17:10 -1000
committerPaul Spooren <mail@aparcar.org>2021-01-30 12:21:58 -1000
commitddab795b370da986149f8c8e6b3455bf9c1066fe (patch)
treea9686c08ee9ea2253559c646783657daddde10e7
parent1b484f1a125190b34fb37226b39d883ac85101d4 (diff)
downloadupstream-ddab795b370da986149f8c8e6b3455bf9c1066fe.tar.gz
upstream-ddab795b370da986149f8c8e6b3455bf9c1066fe.tar.bz2
upstream-ddab795b370da986149f8c8e6b3455bf9c1066fe.zip
rules: fix empty COMMITCOUNT/AUTORELEASE
Packages that are in-tree only often lack a PKG_VERSION and only use the PKG_RELEASE to mark changes. Using COMMITCOUNT/AUTORELEASE variables causes an issue as both variables are empty during the metadata DUMP phase. Instead of leaving these variables empty and causing an error message like below, set the variables to 0 during dumping. On actual building the variable is evaluated causing in a value above 0. ERROR: please fix package/utils/px5g-wolfssl/Makefile - \ see logs/package/utils/px5g-wolfssl/dump.txt for details Makefile:48: *** Package/px5g-wolfssl is missing the VERSION field. Stop. Reported-by: Daniel Golle <daniel@makrotopia.org> Reported-by: Stijn Segers <foss@volatilesystems.org> Reported-by: Stijn Tintel <stijn@linux-ipv6.be> Signed-off-by: Paul Spooren <mail@aparcar.org>
-rw-r--r--rules.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/rules.mk b/rules.mk
index b1b69eabf9..b658e93020 100644
--- a/rules.mk
+++ b/rules.mk
@@ -431,8 +431,8 @@ $(shell \
)
endef
-COMMITCOUNT = $(if $(DUMP),,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),,$(call commitcount,1))
+COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
+AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
all:
FORCE: ;