aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-07-29 15:50:32 +0000
committerJohn Crispin <john@openwrt.org>2007-07-29 15:50:32 +0000
commitdd0a1806eafd0239e7a4b85e3420e711e67d935f (patch)
tree2a1b7de5b56eda88c92195c44c049d15993ddf27
parent1496b6c88be94ab056cf48039c8437a97db5fb4e (diff)
downloadupstream-dd0a1806eafd0239e7a4b85e3420e711e67d935f.tar.gz
upstream-dd0a1806eafd0239e7a4b85e3420e711e67d935f.tar.bz2
upstream-dd0a1806eafd0239e7a4b85e3420e711e67d935f.zip
Some packages make no sense or do not build for etrax
SVN-Revision: 8216
-rw-r--r--package/hostapd/Makefile4
-rw-r--r--package/ipset/Makefile1
-rw-r--r--package/madwifi/Makefile2
-rw-r--r--package/util-linux/Makefile6
4 files changed, 9 insertions, 4 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 7e0f0877f6..86ce414573 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -29,7 +29,7 @@ endef
define Package/hostapd
$(call Package/hostapd/Default)
- DEPENDS:=+libopenssl @!LINUX_2_6_AVR32
+ DEPENDS:=+libopenssl @!LINUX_2_6_AVR32 @!LINUX_2_6_ETRAX
TITLE+= (full)
DESCRIPTION:=\
This package contains a full featured IEEE 802.1x/WPA/EAP/RADIUS \\\
@@ -42,7 +42,7 @@ endef
define Package/hostapd-mini
$(call Package/hostapd/Default)
- DEPENDS:=@!LINUX_2_6_AVR32
+ DEPENDS:=@!LINUX_2_6_AVR32 @!LINUX_2_6_ETRAX
TITLE+= (WPA-PSK only)
DESCRIPTION:=\
This package contains a minimal IEEE 802.1x/WPA/EAP/RADIUS Authenticator \\\
diff --git a/package/ipset/Makefile b/package/ipset/Makefile
index bcc80840a3..62e63d36ee 100644
--- a/package/ipset/Makefile
+++ b/package/ipset/Makefile
@@ -21,6 +21,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/ipset
SECTION:=net
CATEGORY:=Network
+ DEPENDS:=@!LINUX_2_6_ETRAX
TITLE:=Netfilter ip sets administration utility
URL:=http://ipset.netfilter.org/
endef
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 907f191179..f063af800f 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -81,7 +81,7 @@ endif
define KernelPackage/madwifi
SUBMENU:=Wireless Drivers
TITLE:=Driver for Atheros wireless chipsets
- DEPENDS:=+wireless-tools @!LINUX_2_6_AVR32
+ DEPENDS:=+wireless-tools @!LINUX_2_6_AVR32 @!LINUX_2_6_ETRAX
DESCRIPTION:=\
This package contains a driver for Atheros 802.11a/b/g chipsets.
URL:=http://madwifi.org/
diff --git a/package/util-linux/Makefile b/package/util-linux/Makefile
index f624e92ccc..6c5a6972f6 100644
--- a/package/util-linux/Makefile
+++ b/package/util-linux/Makefile
@@ -30,6 +30,7 @@ endef
define Package/fdisk
$(call Package/util-linux/Default)
TITLE:=Partition table manipulation utility
+ DEPENDS:=@!LINUX_2_6_ETRAX
DESCRIPTION:=\
This package contains a utility for managing disk partition tables.
URL:=http://www.kernel.org/pub/linux/utils/util-linux/
@@ -38,7 +39,7 @@ endef
define Package/cfdisk
$(call Package/util-linux/Default)
TITLE:=Partition table manipulation utility
- DEPENDS:=+libncurses
+ DEPENDS:=+libncurses @!LINUX_2_6_ETRAX
DESCRIPTION:=\
This package contains a utility for managing disk partition tables.
URL:=http://www.kernel.org/pub/linux/utils/util-linux/
@@ -47,6 +48,7 @@ endef
define Package/losetup
$(call Package/util-linux/Default)
TITLE:=Loopback devices setup and control utility
+ DEPENDS:=@!LINUX_2_6_ETRAX
DESCRIPTION:=\
This package contains a utility for managing loopback devices.
endef
@@ -54,6 +56,7 @@ endef
define Package/swap-utils
$(call Package/util-linux/Default)
TITLE:=Swap space management utilities
+ DEPENDS:=@!LINUX_2_6_ETRAX
DESCRIPTION:=\
This package contains a collection of tools for managing swap space: \\\
- mkswap\\\
@@ -64,6 +67,7 @@ endef
define Package/hwclock
$(call Package/util-linux/Default)
TITLE:=Utilities for managing the hardware clock
+ DEPENDS:=@!LINUX_2_6_ETRAX
DESCRIPTION:=\
This package contains a utility for managing the hardware clock
endef