aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:42 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:42 +0000
commitd973768580c219115f2e8147fa74bb6dcc74f5ea (patch)
tree3db551bbe3cf01cd75f02cf4f697c7892b29a3ca
parente0837a51f0deb1c30b26076779ca7a19ad8ada79 (diff)
downloadupstream-d973768580c219115f2e8147fa74bb6dcc74f5ea.tar.gz
upstream-d973768580c219115f2e8147fa74bb6dcc74f5ea.tar.bz2
upstream-d973768580c219115f2e8147fa74bb6dcc74f5ea.zip
move x86 specific ide/pata modules to x86' modules.mk
SVN-Revision: 32846
-rw-r--r--package/kernel/modules/block.mk64
-rw-r--r--target/linux/x86/modules.mk73
2 files changed, 73 insertions, 64 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 1f343dd93c..cdf3effc5a 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -489,70 +489,6 @@ endef
$(eval $(call KernelPackage,ide-it821x))
-define KernelPackage/cs5535
- TITLE:=NSC/AMD CS5535 chipset support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_BLK_DEV_CS5535
- FILES=$(LINUX_DIR)/drivers/ide/cs5535.ko
- AUTOLOAD:=$(call AutoLoad,30,cs5535,1)
- $(call AddDepends/ide)
-endef
-
-define KernelPackage/cs5535/description
- Kernel module for the NSC/AMD CS5535 companion chip
-endef
-
-$(eval $(call KernelPackage,cs5535))
-
-
-define KernelPackage/cs5536
- TITLE:=AMD CS5536 chipset support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_BLK_DEV_CS5536
- FILES=$(LINUX_DIR)/drivers/ide/cs5536.ko
- AUTOLOAD:=$(call AutoLoad,30,cs5536,1)
- $(call AddDepends/ide)
-endef
-
-define KernelPackage/cs5536/description
- Kernel module for the AMD CS5536 Geode LX companion chip
-endef
-
-$(eval $(call KernelPackage,cs5536))
-
-
-define KernelPackage/pata-cs5535
- TITLE:=CS5535 PATA support
- DEPENDS:=@TARGET_x86 @PCI_SUPPORT
- KCONFIG:=CONFIG_PATA_CS5535
- FILES=$(LINUX_DIR)/drivers/ata/pata_cs5535.ko
- AUTOLOAD:=$(call AutoLoad,30,pata_cs5535,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/pata-cs5535/description
- Kernel module for the NSC/AMD CS5535 companion chip
-endef
-
-$(eval $(call KernelPackage,pata-cs5535))
-
-
-define KernelPackage/pata-cs5536
- TITLE:=CS5536 PATA support
- DEPENDS:=@TARGET_x86 @PCI_SUPPORT
- KCONFIG:=CONFIG_PATA_CS5536
- FILES=$(LINUX_DIR)/drivers/ata/pata_cs5536.ko
- AUTOLOAD:=$(call AutoLoad,30,pata_cs5536,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/pata-cs5536/description
- Kernel module for the AMD CS5536 Geode LX companion chip
-endef
-
-$(eval $(call KernelPackage,pata-cs5536))
-
-
define KernelPackage/libsas
SUBMENU:=$(BLOCK_MENU)
TITLE:=SAS Domain Transport Attributes
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
new file mode 100644
index 0000000000..0b03a398d9
--- /dev/null
+++ b/target/linux/x86/modules.mk
@@ -0,0 +1,73 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/cs5535
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=NSC/AMD CS5535 chipset support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_BLK_DEV_CS5535
+ FILES=$(LINUX_DIR)/drivers/ide/cs5535.ko
+ AUTOLOAD:=$(call AutoLoad,30,cs5535,1)
+ $(call AddDepends/ide)
+endef
+
+define KernelPackage/cs5535/description
+ Kernel module for the NSC/AMD CS5535 companion chip
+endef
+
+$(eval $(call KernelPackage,cs5535))
+
+
+define KernelPackage/cs5536
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=AMD CS5536 chipset support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_BLK_DEV_CS5536
+ FILES=$(LINUX_DIR)/drivers/ide/cs5536.ko
+ AUTOLOAD:=$(call AutoLoad,30,cs5536,1)
+ $(call AddDepends/ide)
+endef
+
+define KernelPackage/cs5536/description
+ Kernel module for the AMD CS5536 Geode LX companion chip
+endef
+
+$(eval $(call KernelPackage,cs5536))
+
+
+define KernelPackage/pata-cs5535
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=CS5535 PATA support
+ DEPENDS:=@TARGET_x86 @PCI_SUPPORT
+ KCONFIG:=CONFIG_PATA_CS5535
+ FILES=$(LINUX_DIR)/drivers/ata/pata_cs5535.ko
+ AUTOLOAD:=$(call AutoLoad,30,pata_cs5535,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/pata-cs5535/description
+ Kernel module for the NSC/AMD CS5535 companion chip
+endef
+
+$(eval $(call KernelPackage,pata-cs5535))
+
+
+define KernelPackage/pata-cs5536
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=CS5536 PATA support
+ DEPENDS:=@TARGET_x86 @PCI_SUPPORT
+ KCONFIG:=CONFIG_PATA_CS5536
+ FILES=$(LINUX_DIR)/drivers/ata/pata_cs5536.ko
+ AUTOLOAD:=$(call AutoLoad,30,pata_cs5536,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/pata-cs5536/description
+ Kernel module for the AMD CS5536 Geode LX companion chip
+endef
+
+$(eval $(call KernelPackage,pata-cs5536))