aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-09-17 17:53:34 +0200
committerHans Dedecker <dedeckeh@gmail.com>2018-09-19 09:42:45 +0200
commitd9691b66e2781a43cd4f508605dcfe88c4bbd042 (patch)
treee43997281a32a7eeee8b1a5f50d77db26371dfc4
parent1241707b4091aa9dd46ad75252689e83f6aac5b2 (diff)
downloadupstream-d9691b66e2781a43cd4f508605dcfe88c4bbd042.tar.gz
upstream-d9691b66e2781a43cd4f508605dcfe88c4bbd042.tar.bz2
upstream-d9691b66e2781a43cd4f508605dcfe88c4bbd042.zip
map: drop default encaplimit value
Setting encaplimit to a numerical value results into the value being included as tunnel encapsulation limit in the destination option header for tunneled packets. Several users have reported interop issues as not all ISPs support the destination option header containing the tunnel encapsulation limit resulting into broken map connectivity. Therefore drop the default encaplimit value for map tunnels so no destination option header is included by default. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
-rw-r--r--package/network/ipv6/map/Makefile2
-rwxr-xr-xpackage/network/ipv6/map/files/map.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
index cfb7c4ac35..10dbe97b48 100644
--- a/package/network/ipv6/map/Makefile
+++ b/package/network/ipv6/map/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=map
PKG_VERSION:=4
-PKG_RELEASE:=11
+PKG_RELEASE:=12
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/map/files/map.sh b/package/network/ipv6/map/files/map.sh
index 5f4add36eb..70dc72326c 100755
--- a/package/network/ipv6/map/files/map.sh
+++ b/package/network/ipv6/map/files/map.sh
@@ -85,7 +85,7 @@ proto_map_setup() {
json_add_string remote $(eval "echo \$RULE_${k}_BR")
json_add_string link $(eval "echo \$RULE_${k}_PD6IFACE")
json_add_object "data"
- json_add_string encaplimit "${encaplimit:-4}"
+ [ -n "$encaplimit" ] && json_add_string encaplimit "$encaplimit"
if [ "$type" = "map-e" ]; then
json_add_array "fmrs"
for i in $(seq $RULE_COUNT); do