aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2022-03-21 11:47:27 +0100
committerPetr Štetiar <ynezz@true.cz>2022-03-24 08:19:47 +0100
commitd65269a732d82ca9d084c89d6ca05d125d4ab629 (patch)
tree90cd67da5770c815b25c82306303f38480423c4f
parentb9e90935db8e0c0166c80fc6e5e50755282e9e0b (diff)
downloadupstream-d65269a732d82ca9d084c89d6ca05d125d4ab629.tar.gz
upstream-d65269a732d82ca9d084c89d6ca05d125d4ab629.tar.bz2
upstream-d65269a732d82ca9d084c89d6ca05d125d4ab629.zip
mvebu: udpu: fix initramfs booting
uDPU provides a FIT based initramfs, but currently gets stuck after U-boot starts the kernel at "Starting kernel..". It is due to the load address being too low, so increase it in order to get the initramfs booting again. Signed-off-by: Robert Marko <robert.marko@sartura.hr> (cherry picked from commit 80f21e53360d52d493c51a4a263d9b7607b7494e)
-rw-r--r--target/linux/mvebu/image/cortexa53.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/cortexa53.mk b/target/linux/mvebu/image/cortexa53.mk
index dd9d1b379d..bfaa597d9a 100644
--- a/target/linux/mvebu/image/cortexa53.mk
+++ b/target/linux/mvebu/image/cortexa53.mk
@@ -82,7 +82,7 @@ define Device/methode_udpu
DEVICE_VENDOR := Methode
DEVICE_MODEL := micro-DPU (uDPU)
DEVICE_DTS := armada-3720-uDPU
- KERNEL_LOADADDR := 0x00080000
+ KERNEL_LOADADDR := 0x00800000
KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
KERNEL_INITRAMFS_SUFFIX := .itb
DEVICE_PACKAGES += f2fs-tools fdisk kmod-i2c-pxa kmod-hwmon-lm75