aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-12-20 16:06:48 +0000
committerNicolas Thill <nico@openwrt.org>2005-12-20 16:06:48 +0000
commitd351d9bcc97c4d2a75750c963fbafc2a8c79b5cc (patch)
tree438de3e6ee1b8f34c12d6f6f305ac1430c74bb38
parent34bfc1afc78ae6428e632283a0ec76358eec0575 (diff)
downloadupstream-d351d9bcc97c4d2a75750c963fbafc2a8c79b5cc.tar.gz
upstream-d351d9bcc97c4d2a75750c963fbafc2a8c79b5cc.tar.bz2
upstream-d351d9bcc97c4d2a75750c963fbafc2a8c79b5cc.zip
update sane-backends to new upstream release (v1.0.17), add ipkg/conffiles, set svn properties, standardize.
SVN-Revision: 2741
-rw-r--r--openwrt/package/sane-backends/Makefile60
-rw-r--r--openwrt/package/sane-backends/ipkg/sane-backends.conffiles1
2 files changed, 32 insertions, 29 deletions
diff --git a/openwrt/package/sane-backends/Makefile b/openwrt/package/sane-backends/Makefile
index b36e3d7ebb..b3d10b5847 100644
--- a/openwrt/package/sane-backends/Makefile
+++ b/openwrt/package/sane-backends/Makefile
@@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sane-backends
-PKG_VERSION:=1.0.16
+PKG_VERSION:=1.0.17
PKG_RELEASE:=1
-PKG_MD5SUM:=x
+PKG_MD5SUM:=b51c10da8a81a04e1bae88c9e6556df2
PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -22,34 +22,34 @@ $(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(strip $(TARGET_CFLAGS))" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --disable-static \
- --disable-ipv6 \
- --disable-translations \
- --without-gphoto2 \
- --disable-debug \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ --enable-shared \
+ --disable-static \
+ --disable-ipv6 \
+ --disable-translations \
+ --without-gphoto2 \
+ --disable-debug \
);
touch $(PKG_BUILD_DIR)/.configured
@@ -62,6 +62,8 @@ $(PKG_BUILD_DIR)/.built:
touch $(PKG_BUILD_DIR)/.built
$(IPKG_SANE_BACKENDS):
+ install -d -m0755 $(IDIR_SANE_BACKENDS)/etc/sane.d
+ cp -fpR $(PKG_INSTALL_DIR)/etc/sane.d/*.conf $(IDIR_SANE_BACKENDS)/etc/sane.d/
install -d -m0755 $(IDIR_SANE_BACKENDS)/usr/sbin
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/saned $(IDIR_SANE_BACKENDS)/usr/sbin/
$(RSTRIP) $(IDIR_SANE_BACKENDS)
diff --git a/openwrt/package/sane-backends/ipkg/sane-backends.conffiles b/openwrt/package/sane-backends/ipkg/sane-backends.conffiles
new file mode 100644
index 0000000000..a1a6a0b82f
--- /dev/null
+++ b/openwrt/package/sane-backends/ipkg/sane-backends.conffiles
@@ -0,0 +1 @@
+/etc/sane.d/saned.conf