aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-23 10:23:36 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-23 10:23:36 +0000
commitd207116e05aba2a808a2d6b948e56159cecb0e8b (patch)
treedbc5d05543ebdd17141e454c304d4aadb0b27df7
parent3c4edae2cd9027faa2554b8803ce20516af5ee42 (diff)
downloadupstream-d207116e05aba2a808a2d6b948e56159cecb0e8b.tar.gz
upstream-d207116e05aba2a808a2d6b948e56159cecb0e8b.tar.bz2
upstream-d207116e05aba2a808a2d6b948e56159cecb0e8b.zip
add miredo package
SVN-Revision: 2273
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile2
-rw-r--r--openwrt/package/miredo/Config.in48
-rw-r--r--openwrt/package/miredo/Makefile94
-rw-r--r--openwrt/package/miredo/files/miredo-server.init28
-rw-r--r--openwrt/package/miredo/files/miredo.init28
-rw-r--r--openwrt/package/miredo/ipkg/miredo-server.conffiles1
-rw-r--r--openwrt/package/miredo/ipkg/miredo-server.control5
-rw-r--r--openwrt/package/miredo/ipkg/miredo.conffiles1
-rw-r--r--openwrt/package/miredo/ipkg/miredo.control5
10 files changed, 213 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 75955fbadf..3f4b994c15 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -78,6 +78,7 @@ source "package/linux-atm/Config.in"
source "package/maradns/Config.in"
source "package/mini_httpd/Config.in"
source "package/mini_sendmail/Config.in"
+source "package/miredo/Config.in"
source "package/mtr/Config.in"
source "package/ndisc/Config.in"
source "package/net-snmp/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 8f4d32e5c1..0a5f00fdf1 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -109,6 +109,7 @@ package-$(BR2_PACKAGE_MICROCOM) += microcom
package-$(BR2_PACKAGE_MICROPERL) += microperl
package-$(BR2_COMPILE_MINI_HTTPD) += mini_httpd
package-$(BR2_PACKAGE_MINI_SENDMAIL) += mini_sendmail
+package-$(BR2_COMPILE_MIREDO) += miredo
package-$(BR2_COMPILE_MONIT) += monit
package-$(BR2_PACKAGE_MPD) += mpd
package-$(BR2_PACKAGE_MT_DAAPD) += mt-daapd
@@ -253,6 +254,7 @@ libvorbis-compile: libogg-compile
libxml2-compile: zlib-compile
libxslt-compile: libxml2-compile
lighttpd-compile: openssl-compile pcre-compile
+miredo-compile: uclibc++-compile
mt-daapd-compile: howl-compile libgdbm-compile libid3tag-compile
mtr-compile: ncurses-compile
mysql-compile: ncurses-compile zlib-compile
diff --git a/openwrt/package/miredo/Config.in b/openwrt/package/miredo/Config.in
new file mode 100644
index 0000000000..d118052b83
--- /dev/null
+++ b/openwrt/package/miredo/Config.in
@@ -0,0 +1,48 @@
+config BR2_COMPILE_MIREDO
+ tristate
+ default n
+ depends BR2_PACKAGE_MIREDO || BR2_PACKAGE_MIREDO_SERVER
+
+config BR2_PACKAGE_MIREDO
+ prompt "miredo - a Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon"
+ tristate
+ default m if CONFIG_DEVEL
+ select BR2_COMPILE_MIREDO
+ select BR2_PACKAGE_KMOD_IPV6
+ select BR2_PACKAGE_KMOD_TUN
+ select BR2_PACKAGE_LIBPTHREAD
+ select BR2_PACKAGE_UCLIBCXX
+ help
+
+ A Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon.
+
+ http://www.simphalempin.com/dev/miredo/
+
+ Depends:
+ - kmod-ipv6
+ - kmod-tun
+ - libpthread
+ - uClibc++
+
+
+config BR2_PACKAGE_MIREDO_SERVER
+ prompt "miredo-server - a Teredo (IPv6 tunneling over UDP through NAT) server daemon"
+ tristate
+ default m if CONFIG_DEVEL
+ select BR2_COMPILE_MIREDO
+ select BR2_PACKAGE_KMOD_IPV6
+ select BR2_PACKAGE_KMOD_TUN
+ select BR2_PACKAGE_LIBPTHREAD
+ select BR2_PACKAGE_UCLIBCXX
+ help
+
+ A Teredo (IPv6 tunneling over UDP through NAT) server daemon.
+
+ http://www.simphalempin.com/dev/miredo/
+
+ Depends:
+ - kmod-ipv6
+ - kmod-tun
+ - libpthread
+ - uClibc++
+
diff --git a/openwrt/package/miredo/Makefile b/openwrt/package/miredo/Makefile
new file mode 100644
index 0000000000..1632d4f627
--- /dev/null
+++ b/openwrt/package/miredo/Makefile
@@ -0,0 +1,94 @@
+# $Id: Makefile 1728 2005-08-23 00:06:14Z nbd $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=miredo
+PKG_VERSION:=0.5.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=bbbbf60db1346af0bbba6602067ed7ab
+
+PKG_SOURCE_URL:=http://people.via.ecp.fr/~rem/miredo/v0.5/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MIREDO,miredo,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,MIREDO_SERVER,miredo-server,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ ( cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ LIBS="-luClibc++ -lc -lm" \
+ ac_cv_file__proc_self_maps=yes \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ --disable-shared \
+ --enable-static \
+ --with-gnu-ld \
+ --disable-rpath \
+ --disable-chroot \
+ --enable-teredo-client \
+ --enable-teredo-relay \
+ --enable-teredo-server \
+ --enable-miredo-user=root \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CXXLINK="\$$(LINK)" \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ all install
+ touch $@
+
+$(IPKG_MIREDO):
+ install -d -m0755 $(IDIR_MIREDO)/etc
+ cp -fpR $(PKG_INSTALL_DIR)/etc/miredo.conf-dist $(IDIR_MIREDO)/etc/miredo.conf
+ install -d -m0755 $(IDIR_MIREDO)/etc/init.d
+ install -m0755 ./files/miredo.init $(IDIR_MIREDO)/etc/init.d/miredo
+ install -d -m0755 $(IDIR_MIREDO)/usr/sbin
+ cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/miredo $(IDIR_MIREDO)/usr/sbin/
+ $(RSTRIP) $(IDIR_MIREDO)
+ $(IPKG_BUILD) $(IDIR_MIREDO) $(PACKAGE_DIR)
+
+$(IPKG_MIREDO_SERVER):
+ install -d -m0755 $(IDIR_MIREDO_SERVER)/etc/
+ cp -fpR $(PKG_INSTALL_DIR)/etc/miredo-server.conf-dist $(IDIR_MIREDO_SERVER)/etc/miredo-server.conf
+ install -d -m0755 $(IDIR_MIREDO_SERVER)/etc/init.d
+ install -m0755 ./files/miredo-server.init $(IDIR_MIREDO_SERVER)/etc/init.d/miredo-server
+ install -d -m0755 $(IDIR_MIREDO_SERVER)/usr/sbin
+ cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/miredo-server $(IDIR_MIREDO_SERVER)/usr/sbin/
+ $(RSTRIP) $(IDIR_MIREDO_SERVER)
+ $(IPKG_BUILD) $(IDIR_MIREDO_SERVER) $(PACKAGE_DIR)
+
+mostlyclean:
+ -$(MAKE) -C $(PKG_BUILD_DIR) clean
+ rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/miredo/files/miredo-server.init b/openwrt/package/miredo/files/miredo-server.init
new file mode 100644
index 0000000000..b41a86668e
--- /dev/null
+++ b/openwrt/package/miredo/files/miredo-server.init
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+BIN=miredo-server
+DEFAULT=/etc/default/$BIN
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN.pid
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+ [ -d $RUN_D ] || mkdir -p $RUN_D
+ insmod ipv6
+ insmod tun
+ $BIN $OPTIONS
+ ;;
+ stop)
+ [ -f $PID_F ] && kill $(cat $PID_F)
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 (start|stop|restart)"
+ exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/miredo/files/miredo.init b/openwrt/package/miredo/files/miredo.init
new file mode 100644
index 0000000000..e305472aca
--- /dev/null
+++ b/openwrt/package/miredo/files/miredo.init
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+BIN=miredo
+DEFAULT=/etc/default/$BIN
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN.pid
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+ [ -d $RUN_D ] || mkdir -p $RUN_D
+ insmod ipv6
+ insmod tun
+ $BIN $OPTIONS
+ ;;
+ stop)
+ [ -f $PID_F ] && kill $(cat $PID_F)
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 (start|stop|restart)"
+ exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/miredo/ipkg/miredo-server.conffiles b/openwrt/package/miredo/ipkg/miredo-server.conffiles
new file mode 100644
index 0000000000..ca3424bdcf
--- /dev/null
+++ b/openwrt/package/miredo/ipkg/miredo-server.conffiles
@@ -0,0 +1 @@
+/etc/miredo-server.conf
diff --git a/openwrt/package/miredo/ipkg/miredo-server.control b/openwrt/package/miredo/ipkg/miredo-server.control
new file mode 100644
index 0000000000..ebbc3cc584
--- /dev/null
+++ b/openwrt/package/miredo/ipkg/miredo-server.control
@@ -0,0 +1,5 @@
+Package: miredo-server
+Priority: optional
+Section: net
+Depends: kmod-ipv6, kmod-tun, libpthread, uclibc++
+Description: A Teredo (IPv6 tunneling over UDP through NAT) server daemon
diff --git a/openwrt/package/miredo/ipkg/miredo.conffiles b/openwrt/package/miredo/ipkg/miredo.conffiles
new file mode 100644
index 0000000000..f7428b788f
--- /dev/null
+++ b/openwrt/package/miredo/ipkg/miredo.conffiles
@@ -0,0 +1 @@
+/etc/miredo.conf
diff --git a/openwrt/package/miredo/ipkg/miredo.control b/openwrt/package/miredo/ipkg/miredo.control
new file mode 100644
index 0000000000..2794f3bdea
--- /dev/null
+++ b/openwrt/package/miredo/ipkg/miredo.control
@@ -0,0 +1,5 @@
+Package: miredo
+Priority: optional
+Section: net
+Depends: kmod-ipv6, kmod-tun, libpthread, uclibc++
+Description: A Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon