aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-02-28 07:30:30 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-02-28 07:30:30 +0000
commitd0b14b4791475fe234c4d11b9142ca0647eee513 (patch)
tree2938c3ba2e36f560460462b4ae1e5b1a46ed536a
parentf9ffa3755795f84904d370a8dcc7ef390842c282 (diff)
downloadupstream-d0b14b4791475fe234c4d11b9142ca0647eee513.tar.gz
upstream-d0b14b4791475fe234c4d11b9142ca0647eee513.tar.bz2
upstream-d0b14b4791475fe234c4d11b9142ca0647eee513.zip
Added sipp, useful SIP protocol tester
SVN-Revision: 3283
-rw-r--r--openwrt/package/sipp/Config.in13
-rw-r--r--openwrt/package/sipp/Makefile45
-rw-r--r--openwrt/package/sipp/ipkg/sipp.control5
3 files changed, 63 insertions, 0 deletions
diff --git a/openwrt/package/sipp/Config.in b/openwrt/package/sipp/Config.in
new file mode 100644
index 0000000000..1792b1d2bd
--- /dev/null
+++ b/openwrt/package/sipp/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_SIPP
+ prompt "sipp.............................. test tool / traffic generator for the SIP protocol"
+ tristate
+ default m if CONFIG_DEVEL
+ select BR2_PACKAGE_UCLIBCXX
+ select BR2_PACKAGE_LIBPTHREAD
+ select BR2_PACKAGE_LIBNCURSES
+ help
+ SIPp is a free Open Source test tool / traffic generator for the SIP protocol.
+ It includes a few basic SipStone user agent scenarios (UAC and UAS) and
+ establishes and releases multiple calls with the INVITE and BYE methods.
+
+ http://sipp.sourceforge.net
diff --git a/openwrt/package/sipp/Makefile b/openwrt/package/sipp/Makefile
new file mode 100644
index 0000000000..02bc2e2577
--- /dev/null
+++ b/openwrt/package/sipp/Makefile
@@ -0,0 +1,45 @@
+# $Id: Makefile 1146 2005-06-05 13:32:28Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sipp
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+PKG_MD5SUM:=8866e9af0d3bc29e91ebb6eab89a7f1f
+
+PKG_SOURCE_URL:=@SF/sipp
+PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,SIPP,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC) \
+ CC_linux=$(TARGET_CC) \
+ CPP_linux=$(TARGET_CC) \
+ CCLINK_linux=$(TARGET_CC) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS_linux="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -fno-builtin -nostdinc++" \
+ LFLAGS_linux="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ LIBS="-luClibc++ -lc -lm -lgcc -lpthread -ldl -lncurses" \
+ STAGING_DIR=$(STAGING_DIR) \
+ all
+ touch $@
+
+$(IPKG_SIPP):
+ mkdir -p $(IDIR_SIPP)/usr/sbin
+ $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_SIPP)/usr/sbin/
+ $(STRIP) $(IDIR_SIPP)/usr/sbin/*
+ $(IPKG_BUILD) $(IDIR_SIPP) $(PACKAGE_DIR)
+
+mostlyclean:
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/sipp/ipkg/sipp.control b/openwrt/package/sipp/ipkg/sipp.control
new file mode 100644
index 0000000000..3e1b257906
--- /dev/null
+++ b/openwrt/package/sipp/ipkg/sipp.control
@@ -0,0 +1,5 @@
+Package: sipp
+Section: net
+Priority: optional
+Description: traffic generator for the SIP protocol
+Depends: uclibc++, libpthread, libncurses