aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-07-04 11:54:47 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-07-04 14:16:37 +0200
commitd0839e020d0a80b3529a6a8fbbd5d618dfecafa3 (patch)
tree46eb844b852f47ad4119b40ebc89d430b5f59582
parent01ca20cdfd0616fe2b199bd6d97d986f2a554dbe (diff)
downloadupstream-d0839e020d0a80b3529a6a8fbbd5d618dfecafa3.tar.gz
upstream-d0839e020d0a80b3529a6a8fbbd5d618dfecafa3.tar.bz2
upstream-d0839e020d0a80b3529a6a8fbbd5d618dfecafa3.zip
kernel: bump 4.14 to 4.14.53
Refreshed all patches Compile-tested on: cns3xxx, imx6, x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch4
-rw-r--r--target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch2
-rw-r--r--target/linux/mediatek/patches-4.14/0064-dts.patch14
-rw-r--r--target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch2
5 files changed, 13 insertions, 13 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 48c284c6fd..d580cd1ae4 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -4,13 +4,13 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .71
LINUX_VERSION-4.4 = .121
-LINUX_VERSION-4.14 = .52
LINUX_VERSION-4.9 = .111
+LINUX_VERSION-4.14 = .53
LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
-LINUX_KERNEL_HASH-4.14.52 = a5d226c7b2fd1eb0f01d56e4e2c6a0100784b68df907cc7317f32bde34f88810
LINUX_KERNEL_HASH-4.9.111 = 5966558959dc580f163766f3fdefd7e57c01b2b45d51202d00b3807c253759dd
+LINUX_KERNEL_HASH-4.14.53 = a85f2572f97dc551f4a159d0c0858e6f40b925afd2d14a0aa25ee9238da80bbf
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch b/target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
index 2a09caf442..63afabb1d9 100644
--- a/target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
+++ b/target/linux/generic/pending-4.14/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
@@ -8,7 +8,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
--- a/drivers/mtd/ubi/build.c
+++ b/drivers/mtd/ubi/build.c
-@@ -1168,6 +1168,49 @@ static struct mtd_info * __init open_mtd
+@@ -1171,6 +1171,49 @@ static struct mtd_info * __init open_mtd
return mtd;
}
@@ -58,7 +58,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
static int __init ubi_init(void)
{
int err, i, k;
-@@ -1251,6 +1294,12 @@ static int __init ubi_init(void)
+@@ -1254,6 +1297,12 @@ static int __init ubi_init(void)
}
}
diff --git a/target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch b/target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
index 8a9da2c088..4ee79515c9 100644
--- a/target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
+++ b/target/linux/ipq40xx/patches-4.14/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
@@ -17,7 +17,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
--- a/drivers/mtd/ubi/build.c
+++ b/drivers/mtd/ubi/build.c
-@@ -1181,6 +1181,9 @@ static void __init ubi_auto_attach(void)
+@@ -1184,6 +1184,9 @@ static void __init ubi_auto_attach(void)
mtd = open_mtd_device("ubi");
if (IS_ERR(mtd))
mtd = open_mtd_device("data");
diff --git a/target/linux/mediatek/patches-4.14/0064-dts.patch b/target/linux/mediatek/patches-4.14/0064-dts.patch
index cfae4fee64..08feb8d731 100644
--- a/target/linux/mediatek/patches-4.14/0064-dts.patch
+++ b/target/linux/mediatek/patches-4.14/0064-dts.patch
@@ -11,8 +11,8 @@
cpus {
cpu@0 {
proc-supply = <&mt6323_vproc_reg>;
-@@ -102,6 +106,10 @@
- memory@80000000 {
+@@ -103,6 +107,10 @@
+ device_type = "memory";
reg = <0 0x80000000 0 0x40000000>;
};
+
@@ -22,7 +22,7 @@
};
&cir {
-@@ -129,11 +137,24 @@
+@@ -130,11 +138,24 @@
};
};
@@ -49,7 +49,7 @@
compatible = "mediatek,mt7530";
#address-cells = <1>;
#size-cells = <0>;
-@@ -143,6 +164,8 @@
+@@ -144,6 +165,8 @@
core-supply = <&mt6323_vpa_reg>;
io-supply = <&mt6323_vemc3v3_reg>;
@@ -58,7 +58,7 @@
ports {
#address-cells = <1>;
#size-cells = <0>;
-@@ -151,29 +174,46 @@
+@@ -152,29 +175,46 @@
port@0 {
reg = <0>;
label = "wan";
@@ -106,7 +106,7 @@
reg = <6>;
label = "cpu";
ethernet = <&gmac0>;
-@@ -186,8 +226,6 @@
+@@ -187,8 +227,6 @@
};
};
};
@@ -579,7 +579,7 @@
+
--- a/arch/arm/boot/dts/mt7623.dtsi
+++ b/arch/arm/boot/dts/mt7623.dtsi
-@@ -322,6 +322,7 @@
+@@ -323,6 +323,7 @@
"syscon";
reg = <0 0x10209000 0 0x1000>;
#clock-cells = <1>;
diff --git a/target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch b/target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch
index 6e94015dc5..68dd23bdb9 100644
--- a/target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch
+++ b/target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch
@@ -9,7 +9,7 @@ Subject: [PATCH] arm: dts: Add missing mt7623 pcie nodes
--- a/arch/arm/boot/dts/mt7623.dtsi
+++ b/arch/arm/boot/dts/mt7623.dtsi
-@@ -670,6 +670,111 @@
+@@ -671,6 +671,111 @@
#reset-cells = <1>;
};