aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2021-05-16 23:48:04 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2021-05-16 23:59:13 +0200
commitcf3f1f82eaa95c72b3b2620c6da15a81f8d57ba7 (patch)
tree0ae09ede7fb27754a9ff5394961e6797aafff1c6
parentbf8c16dfa2cddd529f889510ca5fa5160606c325 (diff)
downloadupstream-cf3f1f82eaa95c72b3b2620c6da15a81f8d57ba7.tar.gz
upstream-cf3f1f82eaa95c72b3b2620c6da15a81f8d57ba7.tar.bz2
upstream-cf3f1f82eaa95c72b3b2620c6da15a81f8d57ba7.zip
ramips: fix SUPPORTED_DEVICES for ALFA Network devices
Vendor firmware expects model name without manufacturer name inside 'supported_devices' part of metadata. This allows direct upgrade to OpenWrt from vendor's GUI. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
-rw-r--r--target/linux/ramips/image/mt7620.mk3
-rw-r--r--target/linux/ramips/image/mt7621.mk1
-rw-r--r--target/linux/ramips/image/mt76x8.mk1
3 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 3caeecebee..ddb09baa08 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -33,6 +33,7 @@ define Device/alfa-network_ac1200rm
DEVICE_VENDOR := ALFA Network
DEVICE_MODEL := AC1200RM
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci uboot-envtools
+ SUPPORTED_DEVICES += ac1200rm
endef
TARGET_DEVICES += alfa-network_ac1200rm
@@ -43,6 +44,7 @@ define Device/alfa-network_r36m-e4g
DEVICE_MODEL := R36M-E4G
DEVICE_PACKAGES := kmod-i2c-ralink kmod-usb2 kmod-usb-ohci uboot-envtools \
uqmi
+ SUPPORTED_DEVICES += r36m-e4g
endef
TARGET_DEVICES += alfa-network_r36m-e4g
@@ -53,6 +55,7 @@ define Device/alfa-network_tube-e4g
DEVICE_MODEL := Tube-E4G
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci uboot-envtools uqmi -iwinfo \
-kmod-rt2800-soc -wpad-basic-wolfssl
+ SUPPORTED_DEVICES += tube-e4g
endef
TARGET_DEVICES += alfa-network_tube-e4g
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 48448c2ab1..b1c224ca16 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -118,6 +118,7 @@ define Device/alfa-network_quad-e4g
DEVICE_MODEL := Quad-E4G
DEVICE_PACKAGES := kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3 uboot-envtools \
-wpad-basic-wolfssl
+ SUPPORTED_DEVICES += quad-e4g
endef
TARGET_DEVICES += alfa-network_quad-e4g
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index d5a9684dba..c5a0baa1cb 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -34,6 +34,7 @@ define Device/alfa-network_awusfree1
DEVICE_VENDOR := ALFA Network
DEVICE_MODEL := AWUSFREE1
DEVICE_PACKAGES := uboot-envtools
+ SUPPORTED_DEVICES += awusfree1
endef
TARGET_DEVICES += alfa-network_awusfree1