aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-12 01:55:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-12 01:55:28 +0000
commitcf10a1dd5ec950121617cf51b84d00374f86480f (patch)
treea46adfb7283ce958b4a76aeb30369fe34ac682af
parent8838ffd68d915fc356836468e30e7a26f1f6150a (diff)
downloadupstream-cf10a1dd5ec950121617cf51b84d00374f86480f.tar.gz
upstream-cf10a1dd5ec950121617cf51b84d00374f86480f.tar.bz2
upstream-cf10a1dd5ec950121617cf51b84d00374f86480f.zip
another optimization
SVN-Revision: 5507
-rw-r--r--Makefile7
-rw-r--r--include/verbose.mk2
2 files changed, 7 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index d6b1b7d618..62a0338746 100644
--- a/Makefile
+++ b/Makefile
@@ -21,10 +21,15 @@ SHELL:=/usr/bin/env bash
export LC_ALL=C
export LANG=C
export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
ifeq ($(KBUILD_VERBOSE),99)
MAKE:=3>/dev/null $(MAKE)
endif
+ifneq ($(shell tty -s <&3 || echo x),x)
+ IS_TTY=1
+ export IS_TTY
+endif
+
+include $(TOPDIR)/include/verbose.mk
OPENWRTVERSION:=$(RELEASE)
ifneq ($(VERSION),)
diff --git a/include/verbose.mk b/include/verbose.mk
index 34568a31f8..b4242f212a 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -18,7 +18,7 @@ ifeq ("$(origin V)", "command line")
KBUILD_VERBOSE:=$(V)
endif
-ifneq ($(shell tty -s <&3 || echo x),x)
+ifeq ($(IS_TTY),1)
_Y:="\\33[33m"# yellow
_N:="\\33[m"# normal
endif