aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-05-27 21:49:55 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-05-29 13:04:14 +0100
commitcd36c6f52b154e05789e8a2c462a4a0d3fb61cda (patch)
tree2958ccb73ee9385292b98ac70ffcea48280babef
parente018afcfc6ae26d3d41d1a6092962657fe9ec96a (diff)
downloadupstream-cd36c6f52b154e05789e8a2c462a4a0d3fb61cda.tar.gz
upstream-cd36c6f52b154e05789e8a2c462a4a0d3fb61cda.tar.bz2
upstream-cd36c6f52b154e05789e8a2c462a4a0d3fb61cda.zip
mediatek: follow-up with renamed Build/bl2 and Build/bl31-uboot
Use renamed build step names for all boards which were not handled by commit c620409d58 ("mediatek: filogic: add uboot build for mt7981") and now breaking the build. Fixes: c620409d58 ("mediatek: filogic: add uboot build for mt7981") Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 037ce27244b52fe4c0e2bd15f4a16973c64df93f)
-rw-r--r--target/linux/mediatek/image/filogic.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index d1a0a44138..582c1f70b8 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -274,13 +274,13 @@ define Device/tplink_tl-xdr-common
fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb external-static-with-rootfs | append-metadata
DEVICE_PACKAGES := kmod-usb3 kmod-mt7986-firmware mt7986-wo-firmware
ARTIFACTS := preloader.bin bl31-uboot.fip
- ARTIFACT/preloader.bin := bl2 spim-nand-ddr3
+ ARTIFACT/preloader.bin := mt7986-bl2 spim-nand-ddr3
endef
define Device/tplink_tl-xdr4288
DEVICE_MODEL := TL-XDR4288
DEVICE_DTS := mt7986a-tplink-tl-xdr4288
- ARTIFACT/bl31-uboot.fip := bl31-uboot tplink_tl-xdr4288
+ ARTIFACT/bl31-uboot.fip := mt7986-bl31-uboot tplink_tl-xdr4288
$(call Device/tplink_tl-xdr-common)
endef
TARGET_DEVICES += tplink_tl-xdr4288
@@ -288,7 +288,7 @@ TARGET_DEVICES += tplink_tl-xdr4288
define Device/tplink_tl-xdr6086
DEVICE_MODEL := TL-XDR6086
DEVICE_DTS := mt7986a-tplink-tl-xdr6086
- ARTIFACT/bl31-uboot.fip := bl31-uboot tplink_tl-xdr6086
+ ARTIFACT/bl31-uboot.fip := mt7986-bl31-uboot tplink_tl-xdr6086
$(call Device/tplink_tl-xdr-common)
endef
TARGET_DEVICES += tplink_tl-xdr6086
@@ -296,7 +296,7 @@ TARGET_DEVICES += tplink_tl-xdr6086
define Device/tplink_tl-xdr6088
DEVICE_MODEL := TL-XDR6088
DEVICE_DTS := mt7986a-tplink-tl-xdr6088
- ARTIFACT/bl31-uboot.fip := bl31-uboot tplink_tl-xdr6088
+ ARTIFACT/bl31-uboot.fip := mt7986-bl31-uboot tplink_tl-xdr6088
$(call Device/tplink_tl-xdr-common)
endef
TARGET_DEVICES += tplink_tl-xdr6088
@@ -337,8 +337,8 @@ define Device/xiaomi_redmi-router-ax6000-ubootmod
IMAGE/sysupgrade.itb := append-kernel | \
fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb external-static-with-rootfs | append-metadata
ARTIFACTS := preloader.bin bl31-uboot.fip
- ARTIFACT/preloader.bin := bl2 spim-nand-ddr4
- ARTIFACT/bl31-uboot.fip := bl31-uboot xiaomi_redmi-router-ax6000
+ ARTIFACT/preloader.bin := mt7986-bl2 spim-nand-ddr4
+ ARTIFACT/bl31-uboot.fip := mt7986-bl31-uboot xiaomi_redmi-router-ax6000
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
ARTIFACTS += initramfs-factory.ubi
ARTIFACT/initramfs-factory.ubi := append-image-stage initramfs-recovery.itb | ubinize-kernel