aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiogenes Rengo <rengocbx250@gmail.com>2021-06-25 11:44:40 -0300
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-07-04 18:07:35 +0200
commitcce2e8db564b6e40fb5c1831678d98232f09f305 (patch)
tree40c20e197cebf9bff92fba47227b0db4d6f7ac34
parent12eb5b2384a63427c0062856331fda60a1ebb309 (diff)
downloadupstream-cce2e8db564b6e40fb5c1831678d98232f09f305.tar.gz
upstream-cce2e8db564b6e40fb5c1831678d98232f09f305.tar.bz2
upstream-cce2e8db564b6e40fb5c1831678d98232f09f305.zip
ath79: add support for TP-Link TL-WR941HP v1
Specifications: SOC: Qualcomm Atheros TP9343 (750 MHz) Flash: 8 Mb (GigaDevice GD25Q64CSIG) RAM: 64 Mb (Zentel A3R12E40DBF-8E) Serial: yes, 4-pin header Wlan: Qualcomm Atheros TP9343, antenna: MIM0 3x3:3 RP-SMA 3 x 2.4GHz power amp module Skyworks (SiGe) SE2576L Ethernet: Qualcomm Atheros TP9343 Lan speed: 100M ports: 4 Lan speed: 100M ports: 1 Other info: same case, ram and flash that TP-Link TL-WR841HP, different SOC https://forum.openwrt.org/t/adding-device-support-tp-link-wr941hp/ Label MAC addresses based on vendor firmware: LAN *:ee label WAN *:ef label +1 WLAN *:ee label The label MAC address found in "config" partition at 0x8 Flash instruction: Upload the generated factory firmware on web interface. Signed-off-by: Diogenes Rengo <rengocbx250@gmail.com> [remove various whitespace issues, squash commits, use short 0x0] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/ath79/dts/tp9343_tplink_tl-wr941hp-v1.dts154
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/01_leds4
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk10
-rw-r--r--tools/firmware-utils/src/tplink-safeloader.c31
5 files changed, 201 insertions, 1 deletions
diff --git a/target/linux/ath79/dts/tp9343_tplink_tl-wr941hp-v1.dts b/target/linux/ath79/dts/tp9343_tplink_tl-wr941hp-v1.dts
new file mode 100644
index 0000000000..7451f00740
--- /dev/null
+++ b/target/linux/ath79/dts/tp9343_tplink_tl-wr941hp-v1.dts
@@ -0,0 +1,154 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca956x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "tplink,tl-wr941hp-v1", "qca,tp9343";
+ model = "TP-Link TL-WR941HP v1";
+
+ aliases {
+ label-mac-device = &wmac;
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ re {
+ label = "blue:re";
+ gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi {
+ label = "blue:wifi";
+ gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ led_power: power {
+ label = "blue:power";
+ gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wan_blue {
+ label = "blue:wan";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_red {
+ label = "red:wan";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+
+ lan {
+ label = "blue:lan";
+ gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+ };
+
+ wps {
+ label = "blue:wps";
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ re {
+ label = "range extender button";
+ linux,code = <BTN_0>;
+ gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ wifi {
+ label = "wifi button";
+ linux,code = <KEY_RFKILL>;
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ reset {
+ label = "reset button";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ wps {
+ label = "wps button";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+};
+
+&spi {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "tplink,firmware";
+ label = "firmware";
+ reg = <0x020000 0x730000>;
+ };
+
+ config: partition@750000 {
+ label = "config";
+ reg = <0x750000 0x0a0000>;
+ read-only;
+ };
+
+ art: partition@7f0000 {
+ label = "art";
+ reg = <0x7f0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ phy-handle = <&swphy0>;
+
+ mtd-mac-address = <&config 0x8>;
+ mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+ status = "okay";
+
+ mtd-mac-address = <&config 0x8>;
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&config 0x8>;
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 8044d0c1f2..ffda0253f3 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -374,6 +374,10 @@ tplink,tl-wr842n-v2)
ucidef_set_led_switch "lan3" "LAN3" "green:lan3" "switch0" "0x10"
ucidef_set_led_switch "lan4" "LAN4" "green:lan4" "switch0" "0x02"
;;
+tplink,tl-wr941hp-v1)
+ ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth1" "link tx rx"
+ ucidef_set_led_switch "lan" "LAN" "blue:lan" "switch0" "0x1e"
+ ;;
trendnet,tew-823dru)
ucidef_set_led_netdev "wan" "WAN" "green:planet" "eth0"
;;
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index b7e9d9584f..56cff8c031 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -398,7 +398,8 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth0" "2:lan:3" "3:lan:2" "4:lan:1" "5:lan:4"
;;
- tplink,tl-wr842n-v2)
+ tplink,tl-wr842n-v2)\
+ tplink,tl-wr941hp-v1)
ucidef_set_interface_wan "eth1"
ucidef_add_switch "switch0" \
"0@eth0" "1:lan:4" "2:lan:1" "3:lan:2" "4:lan:3"
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 8b228a73d2..daeac8341f 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -798,6 +798,16 @@ define Device/tplink_tl-wr902ac-v1
endef
TARGET_DEVICES += tplink_tl-wr902ac-v1
+define Device/tplink_tl-wr941hp-v1
+ $(Device/tplink-safeloader)
+ SOC := tp9343
+ DEVICE_MODEL := TL-WR941HP
+ DEVICE_VARIANT := v1
+ TPLINK_BOARD_ID := TL-WR941HP-V1
+ IMAGE_SIZE := 7360k
+endef
+TARGET_DEVICES += tplink_tl-wr941hp-v1
+
define Device/tplink_wbs210-v1
$(Device/tplink-safeloader-okli)
SOC := ar9344
diff --git a/tools/firmware-utils/src/tplink-safeloader.c b/tools/firmware-utils/src/tplink-safeloader.c
index fd154e7e0a..432044882c 100644
--- a/tools/firmware-utils/src/tplink-safeloader.c
+++ b/tools/firmware-utils/src/tplink-safeloader.c
@@ -1930,6 +1930,37 @@ static struct device_info boards[] = {
.last_sysupgrade_partition = "file-system",
},
+ /** Firmware layout for the TL-WR941HP v1 */
+ {
+ .id = "TL-WR941HP-V1",
+ .vendor = "",
+ .support_list =
+ "SupportList:\n"
+ "{product_name:TL-WR941HP,product_ver:1.0.0,special_id:00000000}\n",
+ .part_trail = 0x00,
+ .soft_ver = NULL,
+
+ .partitions = {
+ {"fs-uboot", 0x00000, 0x20000},
+ {"firmware", 0x20000, 0x730000},
+ {"default-mac", 0x750000, 0x00200},
+ {"pin", 0x750200, 0x00200},
+ {"product-info", 0x750400, 0x0fc00},
+ {"soft-version", 0x760000, 0x0b000},
+ {"support-list", 0x76b000, 0x04000},
+ {"profile", 0x770000, 0x04000},
+ {"default-config", 0x774000, 0x0b000},
+ {"user-config", 0x780000, 0x40000},
+ {"partition-table", 0x7c0000, 0x10000},
+ {"log", 0x7d0000, 0x20000},
+ {"radio", 0x7f0000, 0x10000},
+ {NULL, 0, 0}
+ },
+
+ .first_sysupgrade_partition = "os-image",
+ .last_sysupgrade_partition = "file-system",
+ },
+
/** Firmware layout for the TL-WR942N V1 */
{
.id = "TLWR942NV1",