aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-10-08 22:21:13 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-07 14:33:17 +0100
commitcc89c5fe2764cc4d67103491f9209aa96d4cc380 (patch)
treee799c05174cf53bee464f2a6cedfe6d9d6107237
parente030d162f77c816163f92024cf187eac4753d5eb (diff)
downloadupstream-cc89c5fe2764cc4d67103491f9209aa96d4cc380.tar.gz
upstream-cc89c5fe2764cc4d67103491f9209aa96d4cc380.tar.bz2
upstream-cc89c5fe2764cc4d67103491f9209aa96d4cc380.zip
ramips: fix device name of netis WF-2881 to WF2881
The correct model name of WF-2881 is WF2881 without hyphen. The former used boardnames are not added to SUPPORTED_DEVICES, to make it explicit that the sysupgrade-tar image, which is newly added in the previous commit, should not be used to upgrade from older version. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [adjust commit title] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/ramips/dts/mt7621_netis_wf2881.dts (renamed from target/linux/ramips/dts/mt7621_netis_wf-2881.dts)8
-rw-r--r--target/linux/ramips/image/mt7621.mk7
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/board.d/02_network4
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh2
4 files changed, 10 insertions, 11 deletions
diff --git a/target/linux/ramips/dts/mt7621_netis_wf-2881.dts b/target/linux/ramips/dts/mt7621_netis_wf2881.dts
index 9d37583af0..63a4975dcf 100644
--- a/target/linux/ramips/dts/mt7621_netis_wf-2881.dts
+++ b/target/linux/ramips/dts/mt7621_netis_wf2881.dts
@@ -6,8 +6,8 @@
#include <dt-bindings/input/input.h>
/ {
- compatible = "netis,wf-2881", "mediatek,mt7621-soc";
- model = "NETIS WF-2881";
+ compatible = "netis,wf2881", "mediatek,mt7621-soc";
+ model = "NETIS WF2881";
aliases {
led-boot = &led_wps;
@@ -25,14 +25,14 @@
compatible = "gpio-leds";
usb {
- label = "wf-2881:green:usb";
+ label = "wf2881:green:usb";
gpios = <&gpio0 6 GPIO_ACTIVE_LOW>;
trigger-sources = <&xhci_ehci_port1>, <&ehci_port2>;
linux,default-trigger = "usbport";
};
led_wps: wps {
- label = "wf-2881:green:wps";
+ label = "wf2881:green:wps";
gpios = <&gpio0 0 GPIO_ACTIVE_LOW>;
};
};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index fdb71ac5f3..878d70c98e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -624,7 +624,7 @@ define Device/netgear_wndr3700-v5
endef
TARGET_DEVICES += netgear_wndr3700-v5
-define Device/netis_wf-2881
+define Device/netis_wf2881
BLOCKSIZE := 128k
PAGESIZE := 2048
FILESYSTEMS := squashfs
@@ -636,11 +636,10 @@ define Device/netis_wf-2881
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
check-size $$$$(IMAGE_SIZE)
DEVICE_VENDOR := NETIS
- DEVICE_MODEL := WF-2881
+ DEVICE_MODEL := WF2881
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
- SUPPORTED_DEVICES += wf-2881
endef
-TARGET_DEVICES += netis_wf-2881
+TARGET_DEVICES += netis_wf2881
define Device/phicomm_k2p
IMAGE_SIZE := 15744k
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index c0412626f2..9b7b56f0ba 100755
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -43,7 +43,7 @@ ramips_setup_interfaces()
netgear,r6350|\
netgear,r6850|\
netgear,wndr3700-v5|\
- netis,wf-2881|\
+ netis,wf2881|\
wevo,11acnas|\
wevo,w2914ns-v2|\
zio,freezio)
@@ -181,7 +181,7 @@ ramips_setup_macs()
elecom,wrc-1900gst|\
elecom,wrc-2533gst|\
lenovo,newifi-d1|\
- netis,wf-2881|\
+ netis,wf2881|\
phicomm,k2p|\
planex,vr500|\
samknows,whitebox-v8|\
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
index eaddca0a83..465ea0a909 100755
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
@@ -49,7 +49,7 @@ platform_do_upgrade() {
netgear,r6260|\
netgear,r6350|\
netgear,r6850|\
- netis,wf-2881|\
+ netis,wf2881|\
xiaomi,mir3g|\
xiaomi,mir3p)
nand_do_upgrade "$1"