aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-23 14:50:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-23 14:50:15 +0000
commitcc289092b23a5bcee878390e7d2aa5558fc9a4b9 (patch)
tree060cea9d0b24d856e1045d80994e805f2658646f
parent473fc68bd2fea7cac8713c08e069d866ee43fcb3 (diff)
downloadupstream-cc289092b23a5bcee878390e7d2aa5558fc9a4b9.tar.gz
upstream-cc289092b23a5bcee878390e7d2aa5558fc9a4b9.tar.bz2
upstream-cc289092b23a5bcee878390e7d2aa5558fc9a4b9.zip
add -mlong-calls cflag to alsa mips build (patch from #1391)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6349 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/alsa/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/alsa/Makefile b/package/alsa/Makefile
index a814da5109..8aa80e74a5 100644
--- a/package/alsa/Makefile
+++ b/package/alsa/Makefile
@@ -36,7 +36,7 @@ ifeq ($(KERNEL),2.4)
KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
endif
ifeq ($(LINUX_KARCH),mips)
- KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
+ KERNEL_C_OPTS:= -Os -G 0 -mlong-calls -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
endif
endif
ifeq ($(LINUX_KARCH),i386)