aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2022-01-10 17:02:30 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2022-12-04 17:25:45 +0100
commitcbce6c6d9519ab86e11c9752910a4c72dd52cb58 (patch)
tree8cad6ad0bd7c0a5296edae3b55955e693d9d6a0b
parent12b1d2f700188e7f6fbb9761510c83e36079ddc6 (diff)
downloadupstream-cbce6c6d9519ab86e11c9752910a4c72dd52cb58.tar.gz
upstream-cbce6c6d9519ab86e11c9752910a4c72dd52cb58.tar.bz2
upstream-cbce6c6d9519ab86e11c9752910a4c72dd52cb58.zip
kernel: split kernel version to dedicated files
Move the kernel versions and hash to dedicated files. This makes kernel bump quicker and fix some annoying problem with rebasing when multiple kernel bump are proposed. Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com> [Rebased on top of current master] Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com> (cherry picked from commit 0765466a42f46f7357e260866a4284ed567bb7ad) Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [Rebased on top of current openwrt-21.02]
-rw-r--r--include/kernel-5.42
-rw-r--r--include/kernel-version.mk7
2 files changed, 7 insertions, 2 deletions
diff --git a/include/kernel-5.4 b/include/kernel-5.4
new file mode 100644
index 0000000000..cd7de7b8fc
--- /dev/null
+++ b/include/kernel-5.4
@@ -0,0 +1,2 @@
+LINUX_VERSION-5.4 = .225
+LINUX_KERNEL_HASH-5.4.225 = 59f596f6714317955cf481590babcf015aff2bc1900bd8e8dc8f7af73bc560aa
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 7480663923..1edb01df27 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,12 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-5.4 = .225
+KERNEL_DETAILS_FILE=$(INCLUDE_DIR)/kernel-$(KERNEL_PATCHVER)
+ifeq ($(wildcard $(KERNEL_DETAILS_FILE)),)
+ $(error Missing kernel version/hash file for $(KERNEL_PATCHVER). Please create $(KERNEL_DETAILS_FILE))
+endif
-LINUX_KERNEL_HASH-5.4.225 = 59f596f6714317955cf481590babcf015aff2bc1900bd8e8dc8f7af73bc560aa
+include $(KERNEL_DETAILS_FILE)
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))