aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-25 19:00:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-25 19:00:43 +0000
commitca8486a632823e6ed40c0d748cd08387a52615d5 (patch)
treee641e2537849520509b8a5512c5cc55a5d07a708
parent2a0825b4d3af709cbce9f5479ec0128da4bb509a (diff)
downloadupstream-ca8486a632823e6ed40c0d748cd08387a52615d5.tar.gz
upstream-ca8486a632823e6ed40c0d748cd08387a52615d5.tar.bz2
upstream-ca8486a632823e6ed40c0d748cd08387a52615d5.zip
improve support for building on mac os x by improving detection of missing components
SVN-Revision: 14180
-rw-r--r--include/prereq-build.mk14
-rwxr-xr-xscripts/md5sum2
-rw-r--r--tools/Makefile31
3 files changed, 30 insertions, 17 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index d6d2d73a63..f0e1da9810 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -37,6 +37,20 @@ $(eval $(call Require,case-sensitive-fs, \
OpenWrt can only be built on a case-sensitive filesystem \
))
+define Require/getopt
+ getopt --help 2>&1 | grep long >/dev/null
+endef
+$(eval $(call Require,getopt, \
+ Please install GNU getopt \
+))
+
+define Require/fileutils
+ gcp --help || cp --help
+endef
+$(eval $(call Require,fileutils, \
+ Please install GNU fileutils \
+))
+
define Require/working-gcc
echo 'int main(int argc, char **argv) { return 0; }' | \
gcc -x c -o $(TMP_DIR)/a.out -
diff --git a/scripts/md5sum b/scripts/md5sum
new file mode 100755
index 0000000000..a5779c42e6
--- /dev/null
+++ b/scripts/md5sum
@@ -0,0 +1,2 @@
+#!/bin/sh
+cat "$@" | md5
diff --git a/tools/Makefile b/tools/Makefile
index e24044d171..f2e4bafbfe 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -27,23 +27,20 @@ $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
$(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
touch $@
-$(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
- @MD5SUM=`which md5sum 2>/dev/null`; \
- if [ "$@" != "$$MD5SUM" ]; then \
- if [ -x "$$MD5SUM" ]; then \
- ln -sf "$$MD5SUM" "$@"; \
- else \
- cp $(SCRIPT_DIR)/md5sum $(STAGING_DIR_HOST)/bin/; \
- fi; \
- fi
-
-$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
- if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
- ln -sf "$(FIND)" $@; \
- fi
-
-
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)
+define PrepareCommand
+$(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
+ @mkdir -p "$$(dir $$@)"; rm -f "$$@"
+ @export FILE="$$$$(which $(2) 2>/dev/null | grep -v 'not found' | head -n1)"; [ -n "$$$$FILE" ] || { \
+ echo "Command $(1) not found."; false; \
+ }; ln -s "$$$$FILE" "$$@"
+
+endef
+
+$(eval $(call PrepareCommand,find,gfind find))
+$(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
+$(eval $(call PrepareCommand,cp,gcp cp))
+
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp)
$(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
$(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)