aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-21 21:30:30 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-21 21:30:30 +0000
commitca25e61c6caaefb45ef9350367aa5c5a9ccdb156 (patch)
treecac79e7e020582b6eaa0ad33d82c81e173fec111
parente6171dfb2c34715ed07959b234f493914cb69bc5 (diff)
downloadupstream-ca25e61c6caaefb45ef9350367aa5c5a9ccdb156.tar.gz
upstream-ca25e61c6caaefb45ef9350367aa5c5a9ccdb156.tar.bz2
upstream-ca25e61c6caaefb45ef9350367aa5c5a9ccdb156.zip
refresh 3.3 patches
SVN-Revision: 33887
-rw-r--r--target/linux/generic/patches-3.3/060-tcp-ecn-dont-delay-ACKS-after-CE.patch4
-rw-r--r--target/linux/generic/patches-3.3/061-fq_codel-dont-reinit-flow-state.patch9
-rw-r--r--target/linux/generic/patches-3.3/729-phy-tantos.patch6
3 files changed, 6 insertions, 13 deletions
diff --git a/target/linux/generic/patches-3.3/060-tcp-ecn-dont-delay-ACKS-after-CE.patch b/target/linux/generic/patches-3.3/060-tcp-ecn-dont-delay-ACKS-after-CE.patch
index 547e4faf73..6f1cd1247b 100644
--- a/target/linux/generic/patches-3.3/060-tcp-ecn-dont-delay-ACKS-after-CE.patch
+++ b/target/linux/generic/patches-3.3/060-tcp-ecn-dont-delay-ACKS-after-CE.patch
@@ -44,11 +44,9 @@ To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
-diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
-index 2fd2bc9..fa2c2c2 100644
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
-@@ -237,7 +237,11 @@ static inline void TCP_ECN_check_ce(struct tcp_sock *tp, const struct sk_buff *s
+@@ -231,7 +231,11 @@ static inline void TCP_ECN_check_ce(stru
tcp_enter_quickack_mode((struct sock *)tp);
break;
case INET_ECN_CE:
diff --git a/target/linux/generic/patches-3.3/061-fq_codel-dont-reinit-flow-state.patch b/target/linux/generic/patches-3.3/061-fq_codel-dont-reinit-flow-state.patch
index 2e6b219446..6699e98f76 100644
--- a/target/linux/generic/patches-3.3/061-fq_codel-dont-reinit-flow-state.patch
+++ b/target/linux/generic/patches-3.3/061-fq_codel-dont-reinit-flow-state.patch
@@ -16,11 +16,9 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
net/sched/sch_fq_codel.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/net/sched/sch_fq_codel.c b/net/sched/sch_fq_codel.c
-index 9fc1c62..4e606fc 100644
--- a/net/sched/sch_fq_codel.c
+++ b/net/sched/sch_fq_codel.c
-@@ -191,7 +191,6 @@ static int fq_codel_enqueue(struct sk_buff *skb, struct Qdisc *sch)
+@@ -191,7 +191,6 @@ static int fq_codel_enqueue(struct sk_bu
if (list_empty(&flow->flowchain)) {
list_add_tail(&flow->flowchain, &q->new_flows);
@@ -28,7 +26,7 @@ index 9fc1c62..4e606fc 100644
q->new_flow_count++;
flow->deficit = q->quantum;
flow->dropped = 0;
-@@ -418,6 +417,7 @@ static int fq_codel_init(struct Qdisc *sch, struct nlattr *opt)
+@@ -418,6 +417,7 @@ static int fq_codel_init(struct Qdisc *s
struct fq_codel_flow *flow = q->flows + i;
INIT_LIST_HEAD(&flow->flowchain);
@@ -36,6 +34,3 @@ index 9fc1c62..4e606fc 100644
}
}
if (sch->limit >= 1)
---
-1.7.9.5
-
diff --git a/target/linux/generic/patches-3.3/729-phy-tantos.patch b/target/linux/generic/patches-3.3/729-phy-tantos.patch
index 0466d94b42..99a4e71e5d 100644
--- a/target/linux/generic/patches-3.3/729-phy-tantos.patch
+++ b/target/linux/generic/patches-3.3/729-phy-tantos.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -206,3 +206,8 @@ endif # PHYLIB
+@@ -210,3 +210,8 @@ endif # PHYLIB
config MICREL_KS8995MA
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
depends on SPI
@@ -11,8 +11,8 @@
+ select ETHERNET_PACKET_MANGLE
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb
- obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+@@ -29,6 +29,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_MICREL_PHY) += micrel.o
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o