aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Roederer <devel-sven@geroedel.de>2017-01-22 19:00:51 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-26 18:07:37 +0100
commitc7a7e7c94ea5cae7260779821648ccaaca6cb8dc (patch)
tree986d3a7b5764f9cc83de70bc237588dcbd062dfe
parentdde5c729ec92cbb11cf6367d93887e634b0ac756 (diff)
downloadupstream-c7a7e7c94ea5cae7260779821648ccaaca6cb8dc.tar.gz
upstream-c7a7e7c94ea5cae7260779821648ccaaca6cb8dc.tar.bz2
upstream-c7a7e7c94ea5cae7260779821648ccaaca6cb8dc.zip
openvpn: ssl-enabled variants also provide a virtual openvpn-crypto package
When relying on x.509 certs for auth and / or encryption of traffic you can't use package openvpn-nossl. Just have your package depend on openvpn-crypto to have SSL-encryption and X.509-support enabled in OpenVPN. If encryption / X.509 is not a must, use virtual packge openvpn, which is provided by all OpenVPN-variants. Signed-off-by: Sven Roederer <devel-sven@geroedel.de>
-rw-r--r--package/network/services/openvpn/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/network/services/openvpn/Makefile b/package/network/services/openvpn/Makefile
index 80aab0b2eb..7507e2029b 100644
--- a/package/network/services/openvpn/Makefile
+++ b/package/network/services/openvpn/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openvpn
PKG_VERSION:=2.4.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=http://swupdate.openvpn.net/community/releases
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -34,7 +34,11 @@ define Package/openvpn/Default
MENU:=1
DEPENDS:=+kmod-tun +OPENVPN_$(1)_ENABLE_LZO:liblzo +OPENVPN_$(1)_ENABLE_IPROUTE2:ip $(3)
VARIANT:=$(1)
+ifeq ($(1),nossl)
PROVIDES:=openvpn
+else
+ PROVIDES:=openvpn openvpn-crypto
+endif
MAINTAINER:=Mirko Vogt <mirko@openwrt.org>
endef